summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/tinyxml/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/tinyxml/files')
-rw-r--r--dev-libs/tinyxml/files/Makefile-344
-rw-r--r--dev-libs/tinyxml/files/tinyxml-2.6.1-entity.patch64
-rw-r--r--dev-libs/tinyxml/files/tinyxml-2.6.2-defineSTL.patch12
-rw-r--r--dev-libs/tinyxml/files/tinyxml.pc.patch14
4 files changed, 0 insertions, 134 deletions
diff --git a/dev-libs/tinyxml/files/Makefile-3 b/dev-libs/tinyxml/files/Makefile-3
deleted file mode 100644
index 40ad4fe7e9ce..000000000000
--- a/dev-libs/tinyxml/files/Makefile-3
+++ /dev/null
@@ -1,44 +0,0 @@
-AR ?= ar
-CXX ?= g++
-CXXFLAGS += -Wall
-RANLIB ?= ranlib
-LIBDIR ?= /usr/lib
-
-name = libtinyxml
-major = @MAJOR_V@
-minor = @MINOR_V@
-version = $(major).$(minor)
-
-src = tinyxml.cpp tinyxmlparser.cpp tinyxmlerror.cpp tinystr.cpp
-lo = $(addsuffix .lo,$(basename ${src}))
-o = $(addsuffix .o,$(basename ${src}))
-
-lib = so
-ifeq ($(shell uname),Darwin)
- lib = dylib
-endif
-
-all: $(name).a $(name).$(lib)
-
-%.o: %.cpp
- $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) $< -o $@
-
-$(name).a: $(o)
- $(AR) rc $(name).a $(o)
- $(RANLIB) $(name).a
-
-%.lo: %.cpp
- $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) -fPIC $< -o $@
-
-$(name).so: $(lo)
- $(CXX) $(LDFLAGS) -fPIC -shared $(lo) -Wl,-soname,$(name).so.$(major) -o $(name).so.$(version)
- ln -s $(name).so.$(version) $(name).so.$(major)
- ln -s $(name).so.$(version) $(name).so
-
-$(name).dylib: $(lo)
- $(CXX) $(LDFLAGS) -fPIC -dynamiclib $(lo) -install_name $(LIBDIR)/$(name).$(major).dylib -o $(name).$(version).dylib
- ln -s $(name).$(version).dylib $(name).$(major).dylib
- ln -s $(name).$(version).dylib $(name).dylib
-
-clean:
- -rm -f *.o *.lo *.so* *.a
diff --git a/dev-libs/tinyxml/files/tinyxml-2.6.1-entity.patch b/dev-libs/tinyxml/files/tinyxml-2.6.1-entity.patch
deleted file mode 100644
index 66d89a61743d..000000000000
--- a/dev-libs/tinyxml/files/tinyxml-2.6.1-entity.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-? entity.patch
-Index: tinyxml.cpp
-===================================================================
-RCS file: /cvsroot/tinyxml/tinyxml/tinyxml.cpp,v
-retrieving revision 1.105
-diff -u -r1.105 tinyxml.cpp
---- tinyxml.cpp 5 Jun 2010 19:06:57 -0000 1.105
-+++ tinyxml.cpp 19 Jul 2010 21:24:16 -0000
-@@ -57,30 +57,7 @@
- {
- unsigned char c = (unsigned char) str[i];
-
-- if ( c == '&'
-- && i < ( (int)str.length() - 2 )
-- && str[i+1] == '#'
-- && str[i+2] == 'x' )
-- {
-- // Hexadecimal character reference.
-- // Pass through unchanged.
-- // &#xA9; -- copyright symbol, for example.
-- //
-- // The -1 is a bug fix from Rob Laveaux. It keeps
-- // an overflow from happening if there is no ';'.
-- // There are actually 2 ways to exit this loop -
-- // while fails (error case) and break (semicolon found).
-- // However, there is no mechanism (currently) for
-- // this function to return an error.
-- while ( i<(int)str.length()-1 )
-- {
-- outString->append( str.c_str() + i, 1 );
-- ++i;
-- if ( str[i] == ';' )
-- break;
-- }
-- }
-- else if ( c == '&' )
-+ if ( c == '&' )
- {
- outString->append( entity[0].str, entity[0].strLength );
- ++i;
-Index: xmltest.cpp
-===================================================================
-RCS file: /cvsroot/tinyxml/tinyxml/xmltest.cpp,v
-retrieving revision 1.89
-diff -u -r1.89 xmltest.cpp
---- xmltest.cpp 5 Jun 2010 17:41:52 -0000 1.89
-+++ xmltest.cpp 19 Jul 2010 21:24:16 -0000
-@@ -1340,6 +1340,16 @@
- }*/
- }
-
-+ #ifdef TIXML_USE_STL
-+ {
-+ TiXmlDocument xml;
-+ xml.Parse("<foo>foo&amp;#xa+bar</foo>");
-+ std::string str;
-+ str << xml;
-+ XmlTest( "Entity escaping", "<foo>foo&amp;#xa+bar</foo>", str.c_str() );
-+ }
-+ #endif
-+
- /* 1417717 experiment
- {
- TiXmlDocument xml;
diff --git a/dev-libs/tinyxml/files/tinyxml-2.6.2-defineSTL.patch b/dev-libs/tinyxml/files/tinyxml-2.6.2-defineSTL.patch
deleted file mode 100644
index 7bcde59ff946..000000000000
--- a/dev-libs/tinyxml/files/tinyxml-2.6.2-defineSTL.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up tinyxml/tinyxml.h~ tinyxml/tinyxml.h
---- tinyxml/tinyxml.h~ 2007-11-30 22:39:36.000000000 +0100
-+++ tinyxml/tinyxml.h 2007-11-30 22:39:36.000000000 +0100
-@@ -26,6 +26,8 @@ distribution.
- #ifndef TINYXML_INCLUDED
- #define TINYXML_INCLUDED
-
-+#define TIXML_USE_STL 1
-+
- #ifdef _MSC_VER
- #pragma warning( push )
- #pragma warning( disable : 4530 )
diff --git a/dev-libs/tinyxml/files/tinyxml.pc.patch b/dev-libs/tinyxml/files/tinyxml.pc.patch
deleted file mode 100644
index 74cb8042b491..000000000000
--- a/dev-libs/tinyxml/files/tinyxml.pc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur old/tinyxml.pc new/tinyxml.pc
---- /dev/null 1970-01-01 03:00:00.000000000 +0300
-+++ tinyxml.pc 2018-05-07 01:46:25.000000000 +0300
-@@ -0,0 +1,10 @@
-+prefix=/usr
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/lib
-+includedir=${prefix}/include
-+
-+Name: TinyXml
-+Description: simple, small, C++ XML parser
-+Version: 2.6.2
-+Libs: -L${libdir} -ltinyxml
-+Cflags: -I${includedir}