summaryrefslogtreecommitdiff
path: root/dev-libs/thrift/thrift-0.18.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-08 05:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-08 05:59:05 +0000
commit60a831b4d328a261286ac8a4e150437faf49ce69 (patch)
tree52337b9b1241c68f5c589fd12d55502da7d44246 /dev-libs/thrift/thrift-0.18.1-r1.ebuild
parent9c26fcf51085241030a088f8ac16051c756386cd (diff)
gentoo auto-resync : 08:03:2023 - 05:59:05
Diffstat (limited to 'dev-libs/thrift/thrift-0.18.1-r1.ebuild')
-rw-r--r--dev-libs/thrift/thrift-0.18.1-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/thrift/thrift-0.18.1-r1.ebuild b/dev-libs/thrift/thrift-0.18.1-r1.ebuild
new file mode 100644
index 000000000000..06a5cec2205d
--- /dev/null
+++ b/dev-libs/thrift/thrift-0.18.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ bindings for Apache Thrift"
+HOMEPAGE="https://thrift.apache.org/lib/cpp.html"
+SRC_URI="mirror://apache/thrift/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="libevent lua +ssl test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=[nls]
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ libevent? ( dev-libs/libevent:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+REQUIRED_USE="
+ test? ( ssl libevent )
+"
+
+PATCHES=(
+ "${FILESDIR}/thrift-0.16.0-network-tests.patch"
+ "${FILESDIR}/thrift-0.18.1-tests.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CPP=ON
+ -DBUILD_C_GLIB=OFF
+ -DBUILD_JAVA=OFF
+ -DBUILD_JAVASCRIPT=OFF
+ -DBUILD_NODEJS=OFF
+ -DBUILD_PYTHON=OFF
+ -DBUILD_TESTING=$(usex test 'ON' 'OFF')
+ -DWITH_LIBEVENT=$(usex libevent 'ON' 'OFF')
+ -DWITH_OPENSSL=$(usex ssl 'ON' 'OFF')
+ -DWITH_ZLIB=ON
+ -Wno-dev
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ MAKEOPTS="-j1" cmake_src_test
+}