summaryrefslogtreecommitdiff
path: root/dev-libs/stfl/stfl-0.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-libs/stfl/stfl-0.24.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-libs/stfl/stfl-0.24.ebuild')
-rw-r--r--dev-libs/stfl/stfl-0.24.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/stfl/stfl-0.24.ebuild b/dev-libs/stfl/stfl-0.24.ebuild
index 66d866317e5f..bdce7f3941f3 100644
--- a/dev-libs/stfl/stfl-0.24.ebuild
+++ b/dev-libs/stfl/stfl-0.24.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6..8} )
GENTOO_DEPEND_ON_PERL=no
inherit eutils multilib perl-module python-r1 toolchain-funcs
@@ -28,6 +28,12 @@ DEPEND="${RDEPEND}
ruby? ( dev-lang/swig )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.21-python.patch"
+ "${FILESDIR}/${PN}-0.22-soname-symlink.patch"
+ "${FILESDIR}/${PN}-0.22-ruby-sharedlib.patch"
+)
+
src_prepare() {
sed -i \
-e 's/-Os -ggdb//' \
@@ -41,9 +47,7 @@ src_prepare() {
sed -i -e "/install .* libstfl.a/d" Makefile || die
fi
- epatch "${FILESDIR}"/${PN}-0.21-python.patch
- epatch "${FILESDIR}"/${PN}-0.22-soname-symlink.patch
- epatch "${FILESDIR}"/${PN}-0.22-ruby-sharedlib.patch
+ eapply_user
if use perl ; then
echo "FOUND_PERL5=1" >> Makefile.cfg