summaryrefslogtreecommitdiff
path: root/dev-libs/stfl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/stfl/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/stfl/files')
-rw-r--r--dev-libs/stfl/files/stfl-0.21-python.patch39
-rw-r--r--dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch14
-rw-r--r--dev-libs/stfl/files/stfl-0.22-soname-symlink.patch10
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/stfl/files/stfl-0.21-python.patch b/dev-libs/stfl/files/stfl-0.21-python.patch
new file mode 100644
index 000000000000..dbec12b7a6a4
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.21-python.patch
@@ -0,0 +1,39 @@
+diff -ur stfl-0.21.orig/Makefile stfl-0.21/Makefile
+--- stfl-0.21.orig/Makefile 2009-06-19 10:30:52.000000000 -0700
++++ stfl-0.21/Makefile 2009-12-23 15:12:34.986593069 -0800
+@@ -46,7 +46,7 @@
+ rm -f widgets/*.o spl/mod_stfl.so spl/example.db
+ cd perl5 && perl Makefile.PL && make clean && rm -f Makefile.old
+ rm -f perl5/stfl_wrap.c perl5/stfl.pm perl5/build_ok
+- rm -f python/stfl.py python/stfl.pyc python/_stfl.so
++ rm -f python/stfl.py python/_stfl.so
+ rm -f python/stfl_wrap.c python/stfl_wrap.o
+ rm -f ruby/Makefile ruby/stfl_wrap.c ruby/stfl_wrap.o
+ rm -f ruby/stfl.so ruby/build_ok Makefile.deps_new
+diff -ur stfl-0.21.orig/python/Makefile.snippet stfl-0.21/python/Makefile.snippet
+--- stfl-0.21.orig/python/Makefile.snippet 2009-06-18 01:27:16.000000000 -0700
++++ stfl-0.21/python/Makefile.snippet 2009-12-23 15:14:54.237606055 -0800
+@@ -21,20 +21,17 @@
+ PYTHON_VERSION = $(shell python -V 2>&1 | cut -f2 -d' ' | cut -f1-2 -d'.')
+ PYTHON_SITEARCH = $(shell python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
+
+-all: python/_stfl.so python/stfl.py python/stfl.pyc
++all: python/_stfl.so python/stfl.py
+
+ install: install_python
+
+-python/_stfl.so python/stfl.py python/stfl.pyc: libstfl.a stfl.h python/stfl.i swig/*.i
++python/_stfl.so python/stfl.py: libstfl.a stfl.h python/stfl.i swig/*.i
+ cd python && swig -python -threads stfl.i
+ gcc -shared -pthread -fPIC python/stfl_wrap.c -I/usr/include/python$(PYTHON_VERSION) \
+ -I. libstfl.a -lncursesw -o python/_stfl.so
+- cd python && python -c 'import stfl'
+
+-install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
++install_python: python/_stfl.so python/stfl.py
+ mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+- cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+
diff --git a/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch b/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch
new file mode 100644
index 000000000000..90698ec88dd7
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.22-ruby-sharedlib.patch
@@ -0,0 +1,14 @@
+--- stfl-0.22/ruby/Makefile.snippet.orig
++++ stfl-0.22/ruby/Makefile.snippet
+@@ -23,9 +23,9 @@
+
+ install: install_ruby
+
+-ruby/build_ok: libstfl.a stfl.h ruby/stfl.i swig/*.i
++ruby/build_ok: libstfl.so.$(VERSION) stfl.h ruby/stfl.i swig/*.i
+ cd ruby && swig -ruby stfl.i && ruby extconf.rb
+- $(MAKE) -C ruby clean && $(MAKE) -C ruby LIBS+="../libstfl.a -lncursesw" CFLAGS+="-pthread -I.." DLDFLAGS+="-pthread" DESTDIR=$(DESTDIR) prefix=$(prefix) sitedir=$(prefix)/$(libdir)/ruby
++ $(MAKE) -C ruby clean && $(MAKE) -C ruby LIBS+="../libstfl.so.$(VERSION) -lncursesw" CFLAGS+="-pthread -I.." DLDFLAGS+="-pthread" DESTDIR=$(DESTDIR) prefix=$(prefix) sitedir=$(prefix)/$(libdir)/ruby
+ touch ruby/build_ok
+
+ install_ruby: ruby/build_ok
diff --git a/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch b/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch
new file mode 100644
index 000000000000..bfe0595edc76
--- /dev/null
+++ b/dev-libs/stfl/files/stfl-0.22-soname-symlink.patch
@@ -0,0 +1,10 @@
+--- stfl-0.22/Makefile.orig
++++ stfl-0.22/Makefile
+@@ -65,6 +65,7 @@
+ install -m 644 stfl.pc $(DESTDIR)$(prefix)/$(libdir)/pkgconfig/
+ install -m 644 libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)
+ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libstfl.so
++ ln -fs libstfl.so.$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/$(SONAME)
+
+ stfl.pc: stfl.pc.in
+ sed 's,@VERSION@,$(VERSION),g' < $< | sed 's,@PREFIX@,$(prefix),g' > $@