summaryrefslogtreecommitdiff
path: root/dev-libs/stb/stb-20200713.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/stb/stb-20200713.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/stb/stb-20200713.ebuild')
-rw-r--r--dev-libs/stb/stb-20200713.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/stb/stb-20200713.ebuild b/dev-libs/stb/stb-20200713.ebuild
new file mode 100644
index 000000000000..2e4c6ded8b9f
--- /dev/null
+++ b/dev-libs/stb/stb-20200713.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# There are no official releases
+CHECKSUM="b42009b3b9d4ca35bc703f5310eedc74f584be58"
+
+DESCRIPTION="single-file public domain (or MIT licensed) libraries for C/C++"
+HOMEPAGE="https://github.com/nothings/stb"
+SRC_URI="https://github.com/nothings/stb/archive/${CHECKSUM}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE=""
+
+S="${WORKDIR}/${PN}-${CHECKSUM}"
+
+BDEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ # Move the header files in a folder so they don't pollute the include dir
+ mkdir stb || die
+ mv *.h stb/ || die
+}
+
+src_install() {
+ doheader -r stb
+}