summaryrefslogtreecommitdiff
path: root/dev-libs/sord/sord-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/sord/sord-0.12.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/sord/sord-0.12.2.ebuild')
-rw-r--r--dev-libs/sord/sord-0.12.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/sord/sord-0.12.2.ebuild b/dev-libs/sord/sord-0.12.2.ebuild
new file mode 100644
index 000000000000..4ff132693eee
--- /dev/null
+++ b/dev-libs/sord/sord-0.12.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}