summaryrefslogtreecommitdiff
path: root/dev-libs/simdjson/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-libs/simdjson/files
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-libs/simdjson/files')
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch20
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch16
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch21
-rw-r--r--dev-libs/simdjson/files/simdjson-1.0.0-tests.patch17
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch b/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch
new file mode 100644
index 000000000000..f796677655d6
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-dont-bundle-cxxopts.patch
@@ -0,0 +1,20 @@
+diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
+index 76651318..2cc06e9e 100644
+--- a/dependencies/CMakeLists.txt
++++ b/dependencies/CMakeLists.txt
+@@ -133,15 +133,3 @@ endfunction()
+ if(SIMDJSON_COMPETITION)
+ competition_scope_()
+ endif()
+-
+-cmake_dependent_option(SIMDJSON_CXXOPTS "Download cxxopts (necessary for tools)" ON
+- SIMDJSON_ALLOW_DOWNLOADS OFF)
+-
+-if(SIMDJSON_CXXOPTS)
+- set_off(CXXOPTS_BUILD_EXAMPLES)
+- set_off(CXXOPTS_BUILD_TESTS)
+- set_off(CXXOPTS_ENABLE_INSTALL)
+-
+- import_dependency(cxxopts jarro2783/cxxopts 794c975)
+- add_dependency(cxxopts)
+-endif()
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch b/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch
new file mode 100644
index 000000000000..b3cd8558b2ff
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-dont-fetch-data-tarball.patch
@@ -0,0 +1,16 @@
+diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
+index 76651318..da5029c0 100644
+--- a/dependencies/CMakeLists.txt
++++ b/dependencies/CMakeLists.txt
+@@ -19,8 +19,9 @@ if(SIMDJSON_GOOGLE_BENCHMARKS)
+ endif()
+
+ # The bulk of our benchmarking and testing data has been moved simdjson/simdjson-data
+-import_dependency(simdjson-data simdjson/simdjson-data a5b13babe65c1bba7186b41b43d4cbdc20a5c470)
+-add_dependency(simdjson-data)
++if(SIMDJSON_TESTS)
++ add_subdirectory(simdjson-data dependencies/simdjson-data)
++endif()
+
+ # This prevents variables declared with set() from unnecessarily escaping and
+ # should not be called more than once
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch b/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch
new file mode 100644
index 000000000000..10d332315608
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-install-tools.patch
@@ -0,0 +1,21 @@
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index f3eaa054..4eaff3d1 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1,12 +1,13 @@
+-if(TARGET cxxopts) # we only build the tools if cxxopts is available
++if(SIMDJSON_TOOLS)
+ message(STATUS "We have cxxopts as a dependency and we are building the tools (e.g., json2json).")
+- foreach(tool IN ITEMS json2json jsonstats jsonpointer minify)
++ foreach(tool IN ITEMS json2json jsonstats simdjsonpointer minify)
+ add_executable("${tool}" "${tool}.cpp")
+ simdjson_apply_props("${tool}")
+ target_link_libraries(
+ "${tool}" PRIVATE
+- simdjson simdjson-internal-flags simdjson-windows-headers cxxopts
++ simdjson simdjson-internal-flags simdjson-windows-headers
+ )
++ install(TARGETS "${tool}")
+ endforeach()
+ else()
+ message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
diff --git a/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch b/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch
new file mode 100644
index 000000000000..cccbd4494667
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-1.0.0-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 235222a8..8532183a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -221,9 +221,10 @@ add_subdirectory(singleheader)
+ #
+ # Compile tools / tests / benchmarks
+ #
+-add_subdirectory(tests)
++if (SIMDJSON_TESTS)
++ add_subdirectory(tests)
++endif()
+ add_subdirectory(examples)
+-add_subdirectory(benchmark)
+ add_subdirectory(fuzz)
+
+ #