summaryrefslogtreecommitdiff
path: root/dev-libs/simdjson/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/simdjson/files
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/simdjson/files')
-rw-r--r--dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch b/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch
new file mode 100644
index 000000000000..f734a65bd891
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-0.7.0-dont-bundle-cssopts.patch
@@ -0,0 +1,30 @@
+diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
+index 51ab3a31..d3d5e86e 100644
+--- a/dependencies/CMakeLists.txt
++++ b/dependencies/CMakeLists.txt
+@@ -105,6 +105,3 @@ endif()
+ set_off(CXXOPTS_BUILD_EXAMPLES)
+ set_off(CXXOPTS_BUILD_TESTS)
+ set_off(CXXOPTS_ENABLE_INSTALL)
+-
+-import_dependency(cxxopts jarro2783/cxxopts 794c975)
+-add_dependency(cxxopts)
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index f1a82be7..5c36d994 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1,10 +1,7 @@
+-if(TARGET cxxopts) # we only build the tools if cxxopts is available
+ message(STATUS "We have cxxopts as a dependency and we are buiding the tools (e.g., json2json).")
+- link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers cxxopts)
++ link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers)
+ add_executable(json2json json2json.cpp)
+ add_executable(jsonstats jsonstats.cpp)
+- add_executable(jsonpointer jsonpointer.cpp)
++ add_executable(simdjsonpointer jsonpointer.cpp)
+ add_executable(minify minify.cpp)
+-else()
+- message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
+-endif()
+\ No newline at end of file
++ install(TARGETS json2json jsonstats simdjsonpointer minify DESTINATION bin)