summaryrefslogtreecommitdiff
path: root/dev-libs/simde/simde-0.7.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 13:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 13:07:48 +0000
commit7825305c5ddf11fffe24fa30453c4e8468f64305 (patch)
treef3c43caefa7210acc3d8fd79ac82f8ade47a8dc9 /dev-libs/simde/simde-0.7.6-r1.ebuild
parentdc22a05dc2db2827053483e8cab136b33b339307 (diff)
gentoo auto-resync : 08:03:2024 - 13:07:48
Diffstat (limited to 'dev-libs/simde/simde-0.7.6-r1.ebuild')
-rw-r--r--dev-libs/simde/simde-0.7.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/simde/simde-0.7.6-r1.ebuild b/dev-libs/simde/simde-0.7.6-r1.ebuild
new file mode 100644
index 000000000000..2a963a57dd1e
--- /dev/null
+++ b/dev-libs/simde/simde-0.7.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
+HOMEPAGE="https://simd-everywhere.github.io/blog/"
+SRC_URI="
+ https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.6-musl.patch
+)
+
+src_configure() {
+ # *FLAGS are only used for tests (nothing that is installed), and
+ # upstream tests with specific *FLAGS and is otherwise flaky with
+ # -march=native, -mno-*, and such -- unset to be spared headaches.
+ unset {C,CPP,CXX,LD}FLAGS
+
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}