summaryrefslogtreecommitdiff
path: root/dev-libs/sentry-native/sentry-native-0.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
commit3cba520665a0461aa7b0ada016f4a0df717e37a2 (patch)
tree2a653051c7ea63b16724a5da9d583994530ab97b /dev-libs/sentry-native/sentry-native-0.6.7.ebuild
parent8c39538f1e5cf37f42c409a6c742f96abef56f3b (diff)
gentoo auto-resync : 25:12:2023 - 01:35:27
Diffstat (limited to 'dev-libs/sentry-native/sentry-native-0.6.7.ebuild')
-rw-r--r--dev-libs/sentry-native/sentry-native-0.6.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/sentry-native/sentry-native-0.6.7.ebuild b/dev-libs/sentry-native/sentry-native-0.6.7.ebuild
new file mode 100644
index 000000000000..1e3a691a642a
--- /dev/null
+++ b/dev-libs/sentry-native/sentry-native-0.6.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Sentry SDK for C, C++ and native applications"
+HOMEPAGE="https://sentry.io/ https://github.com/getsentry/sentry-native"
+SRC_URI="https://github.com/getsentry/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+breakpad +curl test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ breakpad? (
+ dev-util/breakpad
+ virtual/pkgconfig
+ )
+ curl? ( net-misc/curl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.5_cmake-breakpad.patch
+ "${FILESDIR}"/${PN}-0.6.5_no-fuzz-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DSENTRY_BUILD_EXAMPLES=OFF
+ -DSENTRY_BACKEND=$(usex breakpad "breakpad" "inproc")
+ -DSENTRY_BUILD_TESTS=$(usex test)
+ -DSENTRY_TRANSPORT=$(usex curl "curl" "none")
+ )
+ # Avoid "not used by the project" warnings when USE=-breakpad
+ if use breakpad; then
+ mycmakeargs+=( -DSENTRY_BREAKPAD_SYSTEM=ON )
+ fi
+
+ cmake_src_configure
+}