summaryrefslogtreecommitdiff
path: root/dev-libs/sentry-native/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 03:45:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 03:45:27 +0100
commit102518876412b49c154cd247f5891927304dd8cc (patch)
tree02ee78597f043d94b8f33d37622352c7d9c3276f /dev-libs/sentry-native/files
parentd51fe7680c5270ddf8d324bbe11caab6d1e27ade (diff)
gentoo auto-resync : 22:08:2023 - 03:45:27
Diffstat (limited to 'dev-libs/sentry-native/files')
-rw-r--r--dev-libs/sentry-native/files/sentry-native-0.6.5_no-fuzz-test.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/sentry-native/files/sentry-native-0.6.5_no-fuzz-test.patch b/dev-libs/sentry-native/files/sentry-native-0.6.5_no-fuzz-test.patch
new file mode 100644
index 000000000000..70231c02da9e
--- /dev/null
+++ b/dev-libs/sentry-native/files/sentry-native-0.6.5_no-fuzz-test.patch
@@ -0,0 +1,20 @@
+On the one hand the bundled upstream README only mentions sentry_test_unit
+as a test suite meant for the users to run, on the other comments
+in sentry_fuzz_json sources state that it has to be built in a very
+special - and performance-killing - way in order to work.
+
+--- a/tests/unit/CMakeLists.txt
++++ b/tests/unit/CMakeLists.txt
+@@ -89,6 +89,7 @@
+
+ add_test(NAME sentry_test_unit COMMAND sentry_test_unit)
+
++if(0)
+ add_executable(sentry_fuzz_json
+ ${SENTRY_SOURCES}
+ fuzz.c
+@@ -114,3 +115,4 @@
+ endif()
+
+ add_test(NAME sentry_fuzz_json COMMAND sentry_fuzz_json)
++endif()