summaryrefslogtreecommitdiff
path: root/dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
commit4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (patch)
treeee6d7260a8c03fb6191fead616b7dd50f07a7aa4 /dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild
parentef4d67f1907798e309efed58d673fd60594a14a8 (diff)
gentoo auto-resync : 20:12:2022 - 13:51:21
Diffstat (limited to 'dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild')
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild
new file mode 100644
index 000000000000..d0cf376f0b8d
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE ~DRM_AMDGPU ~DRM_AMDGPU_USERPTR"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-libs/libdrm[video_cards_amdgpu]"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ sed -e "s:ubuntu:gentoo:" -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}