summaryrefslogtreecommitdiff
path: root/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild')
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
new file mode 100644
index 000000000000..e7eb65985846
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-2.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-roc-${PV}"
+ KEYWORDS="~amd64"
+fi
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.0-correctly-install.patch"
+ "${FILESDIR}/${PN}-2.6.0-correctly-install-pc.patch"
+ "${FILESDIR}/${PN}-2.6.0-pc-prefix.patch"
+ "${FILESDIR}/${PN}-2.6.0-do-not-install-kfd_ioctl.h.patch"
+)
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl
+ sys-apps/pciutils"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+src_compile() {
+ cmake-utils_src_compile build-dev
+}
+src_install() {
+ cmake-utils_src_install install-dev
+}