summaryrefslogtreecommitdiff
path: root/dev-libs/rocr-runtime/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/rocr-runtime/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/rocr-runtime/files')
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch42
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch57
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch45
3 files changed, 45 insertions, 99 deletions
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch
deleted file mode 100644
index 2caeebb2bbba..000000000000
--- a/dev-libs/rocr-runtime/files/rocr-runtime-2.0.0-cmake-install-paths.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/51/
-
-commit 2d51a6133f32b72f60fba0e95234aee2b63aa682 (HEAD -> patch-6)
-Author: Craig Andrews <candrews@integralblue.com>
-Date: Mon Jan 7 21:06:14 2019 -0500
-
- Correctly install the library into the system
-
- Install to standard locations in /usr/{lib,include}/lib (as opposed to /usr/hsa/{lib,include}/hsa)
- Use CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR from GNUInstallDirs instead of using "lib" and "include"
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 37a9b09..545f183 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -53,6 +53,7 @@ project( ${CORE_RUNTIME_TARGET} )
-
- list ( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules" )
- include ( utils )
-+include ( GNUInstallDirs )
- include ( hsa_common )
-
- ## Find LibElf
-@@ -176,15 +177,9 @@ if ( "${CMAKE_BUILD_TYPE}" STREQUAL Release )
- add_custom_command ( TARGET ${CORE_RUNTIME_TARGET} POST_BUILD COMMAND ${CMAKE_STRIP} *.so )
- endif ()
-
--## Create symlinks for packaging and install
--add_custom_target ( hsa-link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/include/hsa hsa-link )
--add_custom_target ( ${CORE_RUNTIME_TARGET}.so-link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}.so-link )
--
- ## Set install information
--install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION hsa/lib )
--install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION hsa/include/hsa )
--install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa-link DESTINATION include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
--install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}.so-link DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so )
-+install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
-+install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
-
- ## Packaging directives
- set ( CPACK_PACKAGE_NAME "hsa-rocr-dev" )
-
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch b/dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch
deleted file mode 100644
index aef3d297034e..000000000000
--- a/dev-libs/rocr-runtime/files/rocr-runtime-2.8.0-fix_doorbell_map.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/71
-
-From d2a6ad97eb96a28d8f8b658b26ab94e911886cf2 Mon Sep 17 00:00:00 2001
-From: Sean Keely <Sean.Keely@amd.com>
-Date: Thu, 5 Sep 2019 20:58:57 -0500
-Subject: [PATCH] Correct doorbell_queue_map allocation.
-
-doorbell_queue_map should be allocated unconditionally.
----
- core/runtime/amd_gpu_agent.cpp | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/core/runtime/amd_gpu_agent.cpp b/core/runtime/amd_gpu_agent.cpp
-index 9b79a6b..76df913 100644
---- a/core/runtime/amd_gpu_agent.cpp
-+++ b/core/runtime/amd_gpu_agent.cpp
-@@ -1182,12 +1182,22 @@ void GpuAgent::SyncClocks() {
- }
-
- void GpuAgent::BindTrapHandler() {
-+ // Make an empty map from doorbell index to queue.
-+ // The trap handler uses this to retrieve a wave's amd_queue_t*.
-+ auto doorbell_queue_map_size = MAX_NUM_DOORBELLS * sizeof(amd_queue_t*);
-+
-+ doorbell_queue_map_ = (amd_queue_t**)core::Runtime::runtime_singleton_->system_allocator()(
-+ doorbell_queue_map_size, 0x1000, 0);
-+ assert(doorbell_queue_map_ != NULL && "Doorbell queue map allocation failed");
-+
-+ memset(doorbell_queue_map_, 0, doorbell_queue_map_size);
-+
- if (isa_->GetMajorVersion() == 7) {
- // No trap handler support on Gfx7, soft error.
- return;
- }
-
-- // Disable trap handler on Carrizo until KFD is fixed.
-+ // Disable trap handler on APUs until KFD is fixed.
- if (profile_ == HSA_PROFILE_FULL) {
- return;
- }
-@@ -1195,16 +1205,6 @@ void GpuAgent::BindTrapHandler() {
- // Assemble the trap handler source code.
- AssembleShader("TrapHandler", AssembleTarget::ISA, trap_code_buf_, trap_code_buf_size_);
-
-- // Make an empty map from doorbell index to queue.
-- // The trap handler uses this to retrieve a wave's amd_queue_t*.
-- auto doorbell_queue_map_size = MAX_NUM_DOORBELLS * sizeof(amd_queue_t*);
--
-- doorbell_queue_map_ = (amd_queue_t**)core::Runtime::runtime_singleton_->system_allocator()(
-- doorbell_queue_map_size, 0x1000, 0);
-- assert(doorbell_queue_map_ != NULL && "Doorbell queue map allocation failed");
--
-- memset(doorbell_queue_map_, 0, doorbell_queue_map_size);
--
- // Bind the trap handler to this node.
- HSAKMT_STATUS err = hsaKmtSetTrapHandler(node_id(), trap_code_buf_, trap_code_buf_size_,
- doorbell_queue_map_, doorbell_queue_map_size);
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch
new file mode 100644
index 000000000000..29429d0c4807
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch
@@ -0,0 +1,45 @@
+https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/51
+
+From 09a835e8de2d88e917328a78765a1db423d21920 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Sun, 29 Dec 2019 16:57:00 -0500
+Subject: [PATCH] Correctly install the library into the system
+
+Install to standard locations in /usr/{lib,include}/lib (as opposed to /usr/hsa/{lib,include}/hsa)
+Use CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR from GNUInstallDirs instead of using "lib" and "include"
+---
+ CMakeLists.txt | 13 +++----------
+ 1 file changed, 3 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f292182..7474dd2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,6 +61,7 @@ endif() # if (ROCM_CCACHE_BUILD)
+
+ list ( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules" )
+ include ( utils )
++include ( GNUInstallDirs )
+ include ( hsa_common )
+
+ ## Find LibElf
+@@ -176,17 +177,9 @@ endif ()
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY VERSION "${SO_VERSION_STRING}" )
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY SOVERSION "${SO_MAJOR}" )
+
+-## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/include/hsa hsa_include_link )
+-add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+-add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} )
+-
+ ## Set install information
+-install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION hsa/lib )
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION hsa/include/hsa )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} )
++install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ ## Packaging directives
+ set ( CPACK_GENERATOR "DEB;RPM" CACHE STRING "Package types to build")