summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild111
1 files changed, 0 insertions, 111 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild
deleted file mode 100644
index b6912994ddb7..000000000000
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-6.0.0.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ROCM_SKIP_GLOBALS=1
-inherit cmake edo flag-o-matic rocm
-
-DESCRIPTION="Radeon Open Compute OpenCL Compatible Runtime"
-HOMEPAGE="https://github.com/ROCm-Developer-Tools/clr"
-
-#if [[ ${PV} == *9999 ]] ; then
-# EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime"
-# EGIT_CLR_REPO_URI="https://github.com/ROCm-Developer-Tools/ROCclr"
-# inherit git-r3
-# S="${WORKDIR}/${P}"
-#else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/ROCm-Developer-Tools/clr/archive/refs/tags/rocm-${PV}.tar.gz -> rocm-clr-${PV}.tar.gz"
- S="${WORKDIR}/clr-rocm-${PV}/"
-#fi
-
-LICENSE="Apache-2.0 MIT"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-libs/rocr-runtime-6.0
- >=dev-libs/rocm-comgr-6.0
- >=dev-libs/rocm-device-libs-6.0
- >=virtual/opencl-3
- media-libs/mesa[-opencl]"
-DEPEND="${RDEPEND}"
-BDEPEND=">=dev-build/rocm-cmake-5.3
- media-libs/glew
- test? ( >=x11-apps/mesa-progs-8.5.0[X] )
- "
-
-src_unpack () {
-if [[ ${PV} == "9999" ]]; then
- git-r3_fetch
-OB git-r3_checkout
- git-r3_fetch "${EGIT_CLR_REPO_URI}"
- git-r3_checkout "${EGIT_CLR_REPO_URI}" "${CLR_S}"
- else
- default
- fi
-}
-
-src_configure() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/856088
- # https://github.com/ROCm/clr/issues/64
- #
- # Do not trust it for LTO either
- append-flags -fno-strict-aliasing
- filter-lto
-
- # Fix ld.lld linker error: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/155
- append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
-
- # Reported upstream: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/120
- append-cflags -fcommon
-
- local mycmakeargs=(
- -Wno-dev
- -DROCM_PATH="${EPREFIX}/usr"
- -DBUILD_TESTS=$(usex test ON OFF)
- -DEMU_ENV=ON
- -DBUILD_ICD=ON
- -DFILE_REORG_BACKWARD_COMPATIBILITY=OFF
- -DCLR_BUILD_OCL=on
- )
- cmake_src_configure
-}
-
-src_install() {
- insinto /etc/OpenCL/vendors
- doins opencl/config/amdocl64.icd
-
- cd "${BUILD_DIR}"/opencl || die
- insinto /usr/lib64
- doins amdocl/libamdocl64.so
- doins tools/cltrace/libcltrace.so
-}
-
-src_test() {
- check_amdgpu
- cd "${BUILD_DIR}"/tests/ocltst || die
- export OCL_ICD_FILENAMES="${BUILD_DIR}"/amdocl/libamdocl64.so
- local instruction1="Please start an X server using amdgpu driver (not Xvfb!),"
- local instruction2="and export OCLGL_DISPLAY=\${DISPLAY} OCLGL_XAUTHORITY=\${XAUTHORITY} before reruning the test."
- if [[ -n ${OCLGL_DISPLAY+x} ]]; then
- export DISPLAY=${OCLGL_DISPLAY}
- export XAUTHORITY=${OCLGL_XAUTHORITY}
- ebegin "Running oclgl test under DISPLAY ${OCLGL_DISPLAY}"
- if ! glxinfo | grep "OpenGL vendor string: AMD"; then
- ewarn "${instruction1}"
- ewarn "${instruction2}"
- die "This display does not have AMD OpenGL vendor!"
- fi
- ./ocltst -m $(realpath liboclgl.so) -A ogl.exclude
- eend $? || die "oclgl test failed"
- else
- ewarn "${instruction1}"
- ewarn "${instruction2}"
- die "\${OCLGL_DISPLAY} not set."
- fi
- edob ./ocltst -m $(realpath liboclruntime.so) -A oclruntime.exclude
- edob ./ocltst -m $(realpath liboclperf.so) -A oclperf.exclude
-}