summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
commit26f79803004cb53e92cf2f0e889de89979385aa9 (patch)
treed46d17cb971a2dffbe96669e4ad8d341eb5ee3c7 /dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild
parentc5572b13d51970d6603acd131f27991cc1b66a79 (diff)
gentoo auto-resync : 19:11:2022 - 13:00:31
Diffstat (limited to 'dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild')
-rw-r--r--dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild b/dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild
deleted file mode 100644
index 61871fbface9..000000000000
--- a/dev-libs/rocm-device-libs/rocm-device-libs-5.1.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake llvm
-
-LLVM_MAX_SLOT=14
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
- inherit git-r3
- S="${WORKDIR}/${P}/src"
-else
- SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/ROCm-Device-Libs-rocm-${PV}"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Radeon Open Compute Device Libraries"
-HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-devel/clang:${LLVM_MAX_SLOT}"
-DEPEND="${RDEPEND}"
-
-CMAKE_BUILD_TYPE=Release
-
-PATCHES=( "${FILESDIR}/${PN}-5.1.3-test-bitcode-dir.patch"
- "${FILESDIR}/${PN}-5.1.3-llvm-link.patch" )
-
-src_prepare() {
- sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/OCL.cmake" || die
- sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/Packages.cmake" || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DLLVM_DIR="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
- )
- cmake_src_configure
-}