summaryrefslogtreecommitdiff
path: root/dev-libs/rlog/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
commit618c3037024b4e5328531cdc07c6ceb7486f5329 (patch)
tree7c9f8d50c6f5fbd53f3df583c471f5d2e5c34202 /dev-libs/rlog/files
parent76dfef0cec9170000357d2f354e412daf48941fc (diff)
gentoo resync : 31.12.2017 (final resync this year)
Diffstat (limited to 'dev-libs/rlog/files')
-rw-r--r--dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch4
-rw-r--r--dev-libs/rlog/files/rlog-1.4-fix-build-system.patch59
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
index 5e4bb91bf1e3..07770791cd77 100644
--- a/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
+++ b/dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
@@ -1,5 +1,5 @@
---- rlog/RLogChannel.cpp
-+++ rlog/RLogChannel.cpp
+--- a/rlog/RLogChannel.cpp
++++ b/rlog/RLogChannel.cpp
@@ -20,6 +20,7 @@
#include "RLogChannel.h"
#include "rlog.h"
diff --git a/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..b7959a79cd02
--- /dev/null
+++ b/dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
@@ -0,0 +1,59 @@
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -1,15 +1,13 @@
+
+ SOURCES = index.dox channel.dox component.dox
+
+-docdir = $(datadir)/doc
+-pkgdocdir = $(docdir)/$(PACKAGE)
+ #pkghtmldir = $(pkgdocdir)/html
+
+
+ # have both html and html/index.html to force build of index.html if necessary
+ EXTRA_DIST = latex/refman.pdf html html/index.html $(SOURCES)
+
+-pkgdoc_DATA = \
++pdf_DATA = \
+ latex/refman.pdf
+
+ #pkghtml_DATA = \
+@@ -17,22 +15,21 @@
+
+ if BUILD_DOCS
+ latex/refman.pdf: html/index.html
+- -cd latex && make
++ $(MAKE) -C latex
+
+ html/index.html: ../Doxyfile $(SOURCES)
+- -rm -rf html
+- -cd .. && @DOXYGEN@ Doxyfile
++ rm -rf html && $(DOXYGEN) Doxyfile
+
+ clean-local:
+- -rm -rf html
+- -rm -rf latex
++ rm -rf html
++ rm -rf latex
+ endif
+
+ all-local: html/index.html
+
+-install-data-local: all-local
+- -echo installing to ${DESTDIR}${pkgdocdir}/html
+- /bin/sh ../mkinstalldirs ${DESTDIR}${pkgdocdir}/html
+- install html/* ${DESTDIR}${pkgdocdir}/html
++install-data-hook: all-local
++ -echo installing to $(DESTDIR)$(htmldir)
++ /bin/sh ../mkinstalldirs $(DESTDIR)$(htmldir)
++ install html/* $(DESTDIR)$(htmldir)
+
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,6 +10,3 @@
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = librlog.pc
+
+-documentation:
+- cd docs && make
+-