summaryrefslogtreecommitdiff
path: root/dev-libs/redland-bindings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-libs/redland-bindings
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-libs/redland-bindings')
-rw-r--r--dev-libs/redland-bindings/Manifest1
-rw-r--r--dev-libs/redland-bindings/redland-bindings-1.0.17.1-r100.ebuild190
2 files changed, 191 insertions, 0 deletions
diff --git a/dev-libs/redland-bindings/Manifest b/dev-libs/redland-bindings/Manifest
index e489cf3f6827..1bb770df10ac 100644
--- a/dev-libs/redland-bindings/Manifest
+++ b/dev-libs/redland-bindings/Manifest
@@ -3,4 +3,5 @@ AUX redland-bindings-1.0.17.1-bool.patch 502 BLAKE2B 09ab5d8b5b3cf2edd046830bbc8
AUX redland-bindings-1.0.17.1-php-config-r1.patch 2249 BLAKE2B 83d9a65d6db9411531b827d25aaaec721b6756c4a5503179a477fa3d452fff4deaa1fdcaa78c66f5cef0b4cb0d36e06a89050e520a2e0fd36694121eb8a71669 SHA512 406e0d0d97c7c181a16c2a72ec291582ada1c1dbec1cdb53ca62ec73f954a1116462b97f3cf85ada4adfc4ebff35081ac4ce0ce9e2b7155e61402dbb64f57c20
DIST redland-bindings-1.0.17.1.tar.gz 933290 BLAKE2B f58524c30958200af1fb3ec0f63b8aa9f3fd2120297321299cdd225ff9eb331f385c4418ed25987b955857e5046b5c6f0589210b807aae0dc6abe0b758d48cfc SHA512 c105d1232555d226d98efdc1e4edc1b6c953fdd004804e40926452b8f91d30159319a50af68fc3cfe242cf180d85383ef3ff925cc65ed5d0652096cc51f4d7c0
EBUILD redland-bindings-1.0.17.1-r1.ebuild 2953 BLAKE2B ee6830dfa326cbba54cdf2e3d9e60a7d39b0f7151cc42a376d1c226ec97388f183b1244b7f5f353228ceab8f4a62d867fd44a5a7070f5466579e7e21e42a4b3d SHA512 9a03375698491ec2b90527c6043a2c6c13388b6b1eff59322b14c70db27b444c96005e19e2d070cce527cdda8e58d2dff127e16a631fc3b0b17024c557dcdf63
+EBUILD redland-bindings-1.0.17.1-r100.ebuild 3931 BLAKE2B d19f5483e5b0e33837e5adc1666d726f168a8213f862777abbbd1e6ce623534d1c7195b4604689bd88257528ea71cb4ac7ba0186cbd73299ccaa01c9d8628799 SHA512 f04b2341c364b5e83bea6ecd5ba005f7fd4136e9b6a50b3ea15148d0f885edf5c6bf2e34f10de62e6bb42619e939abc0d920dd3085a5f25fe06da9a7826610c9
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r100.ebuild b/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r100.ebuild
new file mode 100644
index 000000000000..6f90b14f2944
--- /dev/null
+++ b/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r100.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{6..9} )
+
+USE_PHP="php7-2 php7-3 php7-4"
+PHP_EXT_ECONF_ARGS="--with-php=yes --without-lua --without-perl --without-python --without-ruby"
+PHP_EXT_NAME="redland"
+PHP_EXT_OPTIONAL_USE="php"
+PHP_EXT_SKIP_PATCHES="yes"
+PHP_EXT_SKIP_PHPIZE="yes"
+
+inherit lua php-ext-source-r3 python-single-r1 autotools
+
+DESCRIPTION="Language bindings for Redland"
+HOMEPAGE="http://librdf.org/bindings/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="lua perl python php ruby test"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="sys-apps/sed
+ virtual/pkgconfig"
+
+RDEPEND=">=dev-libs/redland-1.0.14
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* dev-ruby/log4r )
+ php? (
+ php_targets_php7-2? ( dev-lang/php:7.2[-threads] )
+ php_targets_php7-3? ( dev-lang/php:7.3[-threads] )
+ php_targets_php7-4? ( dev-lang/php:7.4[-threads] )
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-2
+ test? (
+ >=dev-libs/redland-1.0.14[berkdb]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bool.patch
+ "${FILESDIR}"/${PN}-1.0.17.1-php-config-r1.patch
+ "${FILESDIR}"/${PN}-1.0.17.1-add-PHP7-support.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # As of version 1.0.17.1, out-of-tree builds fail with:
+ # "error: redland_wrap.c: No such file or directory",
+ # have to copy the sources.
+ use lua && lua_copy_sources
+
+ use php && php-ext-source-r3_src_prepare
+}
+
+lua_src_configure() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ econf \
+ --with-lua="${ELUA}" \
+ --without-perl \
+ --without-php \
+ --without-python \
+ --without-ruby
+
+ popd > /dev/null || die
+}
+
+src_configure() {
+ if use perl || use python || use ruby ; then
+ econf \
+ $(use_with lua) \
+ $(use_with perl) \
+ $(use_with python) \
+ --without-php \
+ $(use_with ruby)
+ fi
+
+ if use lua; then
+ lua_foreach_impl lua_src_configure
+ fi
+
+ use php && php-ext-source-r3_src_configure
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ default_src_compile
+
+ popd > /dev/null || die
+}
+
+src_compile() {
+ if use perl || use python || use ruby ; then
+ default
+ fi
+
+ if use lua; then
+ lua_foreach_impl lua_src_compile
+ fi
+
+ use php && php-ext-source-r3_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ default_src_test
+
+ popd > /dev/null || die
+}
+
+src_test() {
+ if use perl || use python || use ruby ; then
+ default
+ fi
+
+ if use lua; then
+ lua_foreach_impl lua_src_test
+ fi
+
+ if use php ; then
+ local slot
+ for slot in $(php_get_slots) ; do
+ php_init_slot_env "${slot}"
+ cd php || die
+ ${PHPCLI} -v
+ ${PHPCLI} -d "extension=./${PHP_EXT_NAME}.so" -f test.php || die "PHP tests for ${slot} failed!"
+ cd "${S}" || die
+ done
+ fi
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ emake DESTDIR="${D}" INSTALLDIRS=vendor luadir="$(lua_get_cmod_dir)" install
+
+ popd > /dev/null || die
+}
+
+src_install() {
+ if use perl || use python || use ruby ; then
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install
+ fi
+
+ if use lua; then
+ lua_foreach_impl lua_src_install
+ fi
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+
+ use python && python_optimize
+
+ if use php; then
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ exeinto "${EXT_DIR#$EPREFIX}"
+ doexe "php/${PHP_EXT_NAME}.so"
+ done
+
+ php-ext-source-r3_createinifiles
+ fi
+
+ local DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ local HTML_DOCS=( {NEWS,README,RELEASE,TODO}.html )
+ einstalldocs
+}