summaryrefslogtreecommitdiff
path: root/dev-libs/rapidxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/rapidxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/rapidxml')
-rw-r--r--dev-libs/rapidxml/Manifest5
-rw-r--r--dev-libs/rapidxml/files/rapidxml-1.13-clang.patch23
-rw-r--r--dev-libs/rapidxml/metadata.xml11
-rw-r--r--dev-libs/rapidxml/rapidxml-1.13-r1.ebuild26
-rw-r--r--dev-libs/rapidxml/rapidxml-1.13.ebuild21
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/rapidxml/Manifest b/dev-libs/rapidxml/Manifest
new file mode 100644
index 000000000000..841a236ba97d
--- /dev/null
+++ b/dev-libs/rapidxml/Manifest
@@ -0,0 +1,5 @@
+AUX rapidxml-1.13-clang.patch 1723 BLAKE2B 383b584ce31ec95af51ce061b33eb655ad710b86fc20f31d4bb141b3a3154a89a216d20ff26d084de70984aa19457e9c1bd2f8a2f8b10097a91aa0353d2720d1 SHA512 feab3e9058b565353c8929f356f72b16dc8c68e4a2cfaaf476dabd34ae4cf5c21d1b5c5a9ee7b6947aaeb29c3ac7852aab81b0b551c3118f9c86c710f42760aa
+DIST rapidxml-1.13.zip 44163 BLAKE2B 9db90dfca1943c47e95541a323e1210368447c054cf072d6768031488070e375fe2aa78a4e41f61f252d4c487e94cf1e24e4d3756e3f8774b0c2c52ef86959e7 SHA512 6c10583e6631ccdb0217d0a5381172cb4c1046226de6ef1acf398d85e81d145228e14c3016aefcd7b70a1db8631505b048d8b4f5d4b0dbf1811d2482eefdd265
+EBUILD rapidxml-1.13-r1.ebuild 484 BLAKE2B 5d13532aa937f14da842e5fd78efa2f67c42e3f19fc5246ccdfc7049923cd8541ba7bbbb35aba28ebd1d577ffbe18000727499beb481926473ae8cb2d0a63d45 SHA512 aae5424c134b83ede758421c1841e61634392973508d7fd770faed15993d867ce4e1ac3de76a56ea7b502db15767df14b3d61e26ebbed1eef8b7de226bc4d755
+EBUILD rapidxml-1.13.ebuild 413 BLAKE2B a465322a88a228024829439130053dac2fe53e3a8274595bbc135f75c0feb85259d3bc856e3a02920ff0c7e5ffb87a2c407e89fb74551fc07f002b48323cd2e7 SHA512 4d58d277035c54c87a8cb1670602f1b6dde76362e51d1f8e9aa7fdb8942a04ab29a67f11a143a26afad285574c06192e7300f9399a84f32feb8474d988c64b99
+MISC metadata.xml 331 BLAKE2B 76a526f6ca4463cd836f236c88d20308be9ce4660a996c8efec1cb4266c776692e8cdebdea353d9c91f8b86cfdf9e697a2ca8c5ad60b3a790c7c19fd62e41578 SHA512 b38279f1436fa145a86830d5aada7ac41581c16aadab546621a0cabf72c1ca26b275c158a1a051e4b47f16e936c5c93bb7d5f8e386dfa9b5135b434d3034af22
diff --git a/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch b/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch
new file mode 100644
index 000000000000..007ee19fa8dd
--- /dev/null
+++ b/dev-libs/rapidxml/files/rapidxml-1.13-clang.patch
@@ -0,0 +1,23 @@
+--- rapidxml_print.hpp.orig 2015-06-21 15:46:43.330070116 +0200
++++ rapidxml_print.hpp 2015-06-21 15:50:58.745053512 +0200
+@@ -102,6 +102,20 @@
+ ///////////////////////////////////////////////////////////////////////////
+ // Internal printing operations
+
++ // =====================================
++ // fix for clang for this bug in gcc and others: https://sourceforge.net/p/rapidxml/bugs/16/
++
++ template<class OutIt, class Ch> inline OutIt print_children(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_element_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_data_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_cdata_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_declaration_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_comment_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_doctype_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++ template<class OutIt, class Ch> inline OutIt print_pi_node(OutIt out, const xml_node<Ch> *node, int flags, int indent);
++
++ // =====================================
++
+ // Print node
+ template<class OutIt, class Ch>
+ inline OutIt print_node(OutIt out, const xml_node<Ch> *node, int flags, int indent)
diff --git a/dev-libs/rapidxml/metadata.xml b/dev-libs/rapidxml/metadata.xml
new file mode 100644
index 000000000000..8291b1a23f56
--- /dev/null
+++ b/dev-libs/rapidxml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rapidxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild b/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
new file mode 100644
index 000000000000..316fb1fc0d33
--- /dev/null
+++ b/dev-libs/rapidxml/rapidxml-1.13-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Fast XML parser"
+HOMEPAGE="http://rapidxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rapidxml/rapidxml-${PV}.zip"
+
+LICENSE="Boost-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-clang.patch
+}
+
+src_install() {
+ insinto /usr/include/rapidxml
+ doins *.hpp
+ docinto html
+ dodoc manual.html
+}
diff --git a/dev-libs/rapidxml/rapidxml-1.13.ebuild b/dev-libs/rapidxml/rapidxml-1.13.ebuild
new file mode 100644
index 000000000000..4b8625867211
--- /dev/null
+++ b/dev-libs/rapidxml/rapidxml-1.13.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Fast XML parser"
+HOMEPAGE="http://rapidxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rapidxml/rapidxml-${PV}.zip"
+
+LICENSE="Boost-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ insinto /usr/include/rapidxml
+ doins *.hpp
+ dohtml manual.html
+}