summaryrefslogtreecommitdiff
path: root/dev-libs/qhotkey/qhotkey-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 11:55:01 +0100
commit7288c6e5fa05acddbf692a5187d925ef85662b46 (patch)
tree54bfc06561e59d1ad1e6e7bdbd06b76fc4ba0d06 /dev-libs/qhotkey/qhotkey-1.5.0.ebuild
parent5a1fb66df455454109e1de61d38b48f509dc68b8 (diff)
gentoo auto-resync : 18:04:2023 - 11:55:01
Diffstat (limited to 'dev-libs/qhotkey/qhotkey-1.5.0.ebuild')
-rw-r--r--dev-libs/qhotkey/qhotkey-1.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/qhotkey/qhotkey-1.5.0.ebuild b/dev-libs/qhotkey/qhotkey-1.5.0.ebuild
new file mode 100644
index 000000000000..5721563f8374
--- /dev/null
+++ b/dev-libs/qhotkey/qhotkey-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A global shortcut/hotkey library for desktop Qt applications"
+HOMEPAGE="https://github.com/Skycoder42/QHotkey"
+
+MY_PN="QHotkey"
+
+SRC_URI="https://github.com/Skycoder42/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="qt6"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DEPEND="
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtx11extras:5
+ )
+ qt6? (
+ dev-qt/qtbase:6
+ )
+ x11-libs/libX11
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_DEFAULT_MAJOR_VERSION:STRING=$(usex qt6 "6" "5")
+ )
+ cmake_src_configure
+}