summaryrefslogtreecommitdiff
path: root/dev-libs/pugixml/pugixml-1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
commit06c8293a57349047e228438cc7936e7481ab9159 (patch)
tree6da8926004f93c8934f99c570e0953bd8fb2edf3 /dev-libs/pugixml/pugixml-1.13.ebuild
parent670a2ef95331c60f32a0831bfe79445340356b0b (diff)
gentoo auto-resync : 03:11:2022 - 09:11:25
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.13.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.13.ebuild b/dev-libs/pugixml/pugixml-1.13.ebuild
new file mode 100644
index 000000000000..ab15c38b19e9
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ # Use non-release tarball for tests
+ # TODO: ask upstream to include tests in release tarballs?
+ SRC_URI="https://github.com/zeux/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -D${PN^^}_BUILD_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}