summaryrefslogtreecommitdiff
path: root/dev-libs/pugixml/pugixml-1.11.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-libs/pugixml/pugixml-1.11.4.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.11.4.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.11.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.11.4.ebuild b/dev-libs/pugixml/pugixml-1.11.4.ebuild
new file mode 100644
index 000000000000..0750359ebd79
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.11.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+
+LICENSE="MIT"
+SLOT="0"