summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf/protobuf-3.15.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-libs/protobuf/protobuf-3.15.8.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-libs/protobuf/protobuf-3.15.8.ebuild')
-rw-r--r--dev-libs/protobuf/protobuf-3.15.8.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/protobuf/protobuf-3.15.8.ebuild b/dev-libs/protobuf/protobuf-3.15.8.ebuild
index 7fff0e4d377a..751620427fff 100644
--- a/dev-libs/protobuf/protobuf-3.15.8.ebuild
+++ b/dev-libs/protobuf/protobuf-3.15.8.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="BSD"
SLOT="0/26"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="emacs examples static-libs test zlib"
RESTRICT="!test? ( test )"
@@ -49,6 +49,15 @@ src_prepare() {
# https://github.com/protocolbuffers/protobuf/issues/8082
sed -e "/^TEST_F(IoTest, LargeOutput) {$/,/^}$/d" -i src/google/protobuf/io/zero_copy_stream_unittest.cc || die
+ # https://github.com/protocolbuffers/protobuf/issues/8459
+ sed \
+ -e "/^TEST(ArenaTest, BlockSizeSmallerThanAllocation) {$/a\\ if (sizeof(void*) == 4) {\n GTEST_SKIP();\n }" \
+ -e "/^TEST(ArenaTest, SpaceAllocated_and_Used) {$/a\\ if (sizeof(void*) == 4) {\n GTEST_SKIP();\n }" \
+ -i src/google/protobuf/arena_unittest.cc || die
+
+ # https://github.com/protocolbuffers/protobuf/issues/8460
+ sed -e "/^TEST(AnyTest, TestPackFromSerializationExceedsSizeLimit) {$/a\\ if (sizeof(void*) == 4) {\n GTEST_SKIP();\n }" -i src/google/protobuf/any_test.cc || die
+
eautoreconf
}