summaryrefslogtreecommitdiff
path: root/dev-libs/papi/papi-5.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/papi/papi-5.5.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/papi/papi-5.5.1.ebuild')
-rw-r--r--dev-libs/papi/papi-5.5.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/papi/papi-5.5.1.ebuild b/dev-libs/papi/papi-5.5.1.ebuild
new file mode 100644
index 000000000000..0d2f0f2c48e2
--- /dev/null
+++ b/dev-libs/papi/papi-5.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils fortran-2 versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ local myeconfargs=(
+ --with-shlib
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ../RE*
+}