summaryrefslogtreecommitdiff
path: root/dev-libs/opencl-clang/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-libs/opencl-clang/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-libs/opencl-clang/files')
-rw-r--r--dev-libs/opencl-clang/files/opencl-clang-10.0.0.1_find-llvm-tblgen.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/opencl-clang/files/opencl-clang-10.0.0.1_find-llvm-tblgen.patch b/dev-libs/opencl-clang/files/opencl-clang-10.0.0.1_find-llvm-tblgen.patch
new file mode 100644
index 000000000000..bf013c33a596
--- /dev/null
+++ b/dev-libs/opencl-clang/files/opencl-clang-10.0.0.1_find-llvm-tblgen.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -137,7 +137,7 @@
+ set (COMPILE_OPTIONS_TD opencl_clang_options.td)
+ set (COMPILE_OPTIONS_INC opencl_clang_options.inc)
+
+-set(LLVM_TABLEGEN_EXE "llvm-tblgen")
++find_program(LLVM_TABLEGEN_EXE "llvm-tblgen")
+ set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD})
+ if(USE_PREBUILT_LLVM)
+ set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS})