summaryrefslogtreecommitdiff
path: root/dev-libs/nsync/nsync-1.24.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/nsync/nsync-1.24.0-r1.ebuild
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/nsync/nsync-1.24.0-r1.ebuild')
-rw-r--r--dev-libs/nsync/nsync-1.24.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/nsync/nsync-1.24.0-r1.ebuild b/dev-libs/nsync/nsync-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..b707bd898d59
--- /dev/null
+++ b/dev-libs/nsync/nsync-1.24.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C library that exports various synchronization primitives, such as mutexes"
+HOMEPAGE="https://github.com/google/nsync"
+SRC_URI="https://github.com/google/nsync/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DNSYNC_ENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}