summaryrefslogtreecommitdiff
path: root/dev-libs/npth/npth-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
commit85809279ceef66e68b25eac8c3918bee6762f6cc (patch)
tree9ecee133212467e7b1402b70a11c5d6fb3ea817d /dev-libs/npth/npth-1.7-r1.ebuild
parent4215622c05ed14d30fdad5a4d0feba6d94b0d046 (diff)
gentoo auto-resync : 25:02:2024 - 17:40:36
Diffstat (limited to 'dev-libs/npth/npth-1.7-r1.ebuild')
-rw-r--r--dev-libs/npth/npth-1.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/npth/npth-1.7-r1.ebuild b/dev-libs/npth/npth-1.7-r1.ebuild
new file mode 100644
index 000000000000..d390d9c7bb59
--- /dev/null
+++ b/dev-libs/npth/npth-1.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ econf $(use_enable test tests) \
+ --enable-install-npth-config
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}