summaryrefslogtreecommitdiff
path: root/dev-libs/nettle/nettle-3.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
commit996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (patch)
tree16fac72b3f131ad5671db34f88cd6426ff602706 /dev-libs/nettle/nettle-3.9.1.ebuild
parent0cfdfb9b75c154c98f3963d4a002425218e29efc (diff)
gentoo auto-resync : 06:06:2023 - 09:39:05
Diffstat (limited to 'dev-libs/nettle/nettle-3.9.1.ebuild')
-rw-r--r--dev-libs/nettle/nettle-3.9.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-libs/nettle/nettle-3.9.1.ebuild b/dev-libs/nettle/nettle-3.9.1.ebuild
index 8e0867d6b2f1..81c854b6b187 100644
--- a/dev-libs/nettle/nettle-3.9.1.ebuild
+++ b/dev-libs/nettle/nettle-3.9.1.ebuild
@@ -15,7 +15,7 @@ LICENSE="|| ( LGPL-3 LGPL-2.1 )"
# Subslot = libnettle - libhogweed soname version
SLOT="0/8-6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+asm doc +gmp static-libs cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_x86_aes cpu_flags_x86_sha cpu_flags_x86_pclmul"
+IUSE="+asm doc +gmp static-libs cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_sha cpu_flags_x86_pclmul"
# The arm64 crypto option controls AES, SHA1, and SHA2 usage.
REQUIRED_USE="
cpu_flags_arm_aes? ( cpu_flags_arm_sha1 cpu_flags_arm_sha2 )
@@ -63,13 +63,11 @@ multilib_src_configure() {
$(use_enable cpu_flags_arm_neon arm-neon)
$(use_enable cpu_flags_arm_aes arm64-crypto)
$(use_enable cpu_flags_ppc_altivec power-altivec)
+ $(use_enable cpu_flags_ppc_vsx2 power-crypto-ext)
+ $(use_enable cpu_flags_ppc_vsx3 power9)
$(use_enable cpu_flags_x86_aes x86-aesni)
$(use_enable cpu_flags_x86_sha x86-sha-ni)
$(use_enable cpu_flags_x86_pclmul x86-pclmul)
- # TODO: PPC crypto flag?
- --disable-power-crypto-ext
- # TODO: How do we detect this in ebuilds reliably?
- --disable-power9
$([[ ${CHOST} == *-solaris* ]] && echo '--disable-symbol-versions')
# TODO: cpu_flags_s390?
--disable-s390x-vf