summaryrefslogtreecommitdiff
path: root/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild')
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild b/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..b10243ad377a
--- /dev/null
+++ b/dev-libs/nanomsg/nanomsg-1.1.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High-performance messaging interface for distributed applications"
+HOMEPAGE="https://nanomsg.org/"
+SRC_URI="https://github.com/nanomsg/nanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/5.0.0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~riscv x86"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-ruby/asciidoctor )"
+
+src_prepare() {
+ # Old CPUs like HPPA fails test because of timeout
+ sed -i \
+ -e '/inproc_shutdown/s/5/80/' \
+ -e '/ws_async_shutdown/s/5/80/' \
+ -e '/ipc_shutdown/s/30/80/' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNN_STATIC_LIB=OFF
+ -DNN_ENABLE_DOC=$(usex doc)
+ )
+
+ cmake_src_configure
+}