summaryrefslogtreecommitdiff
path: root/dev-libs/nanomsg/nanomsg-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/nanomsg/nanomsg-1.1.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/nanomsg/nanomsg-1.1.4.ebuild')
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.1.4.ebuild b/dev-libs/nanomsg/nanomsg-1.1.4.ebuild
new file mode 100644
index 000000000000..deb63c3d8256
--- /dev/null
+++ b/dev-libs/nanomsg/nanomsg-1.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="High-performance messaging interface for distributed applications"
+HOMEPAGE="https://nanomsg.org/"
+SRC_URI="https://github.com/nanomsg/nanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/5.0.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( dev-ruby/asciidoctor )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNN_STATIC_LIB=$(usex static-libs ON OFF)
+ )
+ if multilib_is_native_abi; then
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=$(usex doc ON OFF)
+ )
+ else
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=OFF
+ -DNN_ENABLE_TOOLS=OFF
+ -DNN_ENABLE-NANOCAT=OFF
+ )
+ fi
+ cmake-utils_src_configure
+}