summaryrefslogtreecommitdiff
path: root/dev-libs/mxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-libs/mxml
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest2
-rw-r--r--dev-libs/mxml/mxml-3.3.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 8cd14842c608..9abb3161a5ee 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1,4 +1,6 @@
AUX mxml-3.2-slibtool.patch 723 BLAKE2B d5e086ac0b600c2314d92224ec37da16b0c1276d2da8032579d95b4ae4eb641c985bd6374411453037779d3cd0d8e86e7d89a445ba263c03d1863968d7e22460 SHA512 3077e580bb44843a09f7a8c80ff05996af70658195eb07e31f5da69409744729e5aacd706ca5f4f91e2ddf75c79f554dbc3667bb6720997c03e8c57ad279db60
DIST mxml-3.2.tar.gz 9267930 BLAKE2B f244dab599233b8a26aba5a11526979bf2f4d20b5fce67858f7759abc5bd2f3e2aac19d512c887248839d130cf1314065687cd1ccf91edbf5533ae2d342f286b SHA512 ed3f2b361394ef225a708b0032976a3d191d5eaea3022e190b29e0ee140e8f998f1d65c64e4898872b169516cee44f4f5f18401c6410c3b5aa1e9680b23e8675
+DIST mxml-3.3.tar.gz 1550358 BLAKE2B 2b815cd8c2031099e2767caad93cc389962ec547fadade92b0a7fb48a2352fd0940c9e434c2081b7419e0cfb489266d7116dacefd6fb9d7ce40d6de0f49cb2a6 SHA512 5a8453bec17e46afc9b100df03dba2219353a076152f34a5dc41b7f042fa570723effc3472680a4380674c412c3ab31e017f6704b1e8308227a4d9b3f13cb197
EBUILD mxml-3.2.ebuild 1456 BLAKE2B 55a8efb6c1e105b247c247de0a347310139f13348ee6e8ddc0096ba915026ddacc1e9cacfce388f0ef77e9ad388a0f7f80eda91087295fb6db3164fba025dfa2 SHA512 506db0f7762d585f208d15202d937d5eb52550ce99fe39450b7d05d5ad904cd0944f9568e554b39931a2824edbad4e461bd4d7308c2ade606818749ab475a092
+EBUILD mxml-3.3.ebuild 1344 BLAKE2B a4889416809a773305d33b4836047a73239bdaef01fda00cc96e44ba2e7407e9e2247c7818954204dfeae9bdd62222c46a3dd88d65a8896efaa8167177fc0490 SHA512 bd1a9555c210bfb16370f6b8ba6ae939c580eae720768414f7da810914506d18872250ea3a272c8e957fc7b94ac560e7a712751aabf762635d43610d7ebef4b0
MISC metadata.xml 1380 BLAKE2B ba169e7d7bf4572b56e2cc8923a48fce4b31af61107bd908d77f4a211aa096b4f0adfed9ae1d52cbad6b4309793f545cbd562a553e0c5aa1d0786b088f472cd7 SHA512 2895d86c62cb799302ba1515a3b638d52ca253f78e07bcc542bbb99338b84bc2079d48f42fb85a627e9252a545a853629943f9a904ead600aff161a24e1f1658
diff --git a/dev-libs/mxml/mxml-3.3.ebuild b/dev-libs/mxml/mxml-3.3.ebuild
new file mode 100644
index 000000000000..a0e3cdb5191b
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}