summaryrefslogtreecommitdiff
path: root/dev-libs/mxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-25 20:57:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-25 20:57:05 +0100
commit26262b314fa723a2e86f4a9b8b344a72eb9c0393 (patch)
tree38c75311fb4f334d6369b07cc6094e809f910dba /dev-libs/mxml
parent22899eb46c1c332d9a8a995c0be0b965fb1bcfc3 (diff)
gentoo auto-resync : 25:07:2022 - 20:57:05
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest2
-rw-r--r--dev-libs/mxml/mxml-3.3.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 8ce555167deb..f9b53b29e021 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1,3 +1,5 @@
+DIST mxml-3.3.1.tar.gz 1554784 BLAKE2B e0d599fd947dfef72edae40c1e70ea76c92105128dd46e772a7c71f9293cab3339c980396dffe105246cad64d0474935cc1939005ad9a2bffc8e8107f025a466 SHA512 43e6a92806d9c3f5db39fbf960c15ebfa6d92ef98274b7ce39b57724d6c26ad4362d6d8f3c1023efda92e6a815df068e5038a0cd479562b6be9dbdda8e827a41
DIST mxml-3.3.tar.gz 1550358 BLAKE2B 2b815cd8c2031099e2767caad93cc389962ec547fadade92b0a7fb48a2352fd0940c9e434c2081b7419e0cfb489266d7116dacefd6fb9d7ce40d6de0f49cb2a6 SHA512 5a8453bec17e46afc9b100df03dba2219353a076152f34a5dc41b7f042fa570723effc3472680a4380674c412c3ab31e017f6704b1e8308227a4d9b3f13cb197
+EBUILD mxml-3.3.1.ebuild 1349 BLAKE2B 0df503d97d6c95b10e070472cc3da4db0f404d3d7f9a2e226f8b57dd3c7635ad53e906fe588ede2f66ef28ffa667409e9b851a830e10c6b829e97e96303ab347 SHA512 b0459b71a912ace9e9fb6c51ebe2b0e4725d1607e5fcf9f339716cf5805ba94ea5f6dd2079e5ac9f79e1a15c364150acb38e23aba0a29e730ac711b7f0359455
EBUILD mxml-3.3.ebuild 1347 BLAKE2B 5a90de864906aaf60f3b3c685de49033cbb170e92b82ef9281a110706c08c9cfb1f7374668e859c2a86fc7e89f78f96cca3ec3f516a9611d0c3131ffe0e11f26 SHA512 d745e253e43e9a49a4eb63fabb1698e925a82127a6ab2e545512e4a2248cd50e52a090992243d8ac1ee42938f86a11911794b3af81fe481e1e24633b831649e1
MISC metadata.xml 1380 BLAKE2B ba169e7d7bf4572b56e2cc8923a48fce4b31af61107bd908d77f4a211aa096b4f0adfed9ae1d52cbad6b4309793f545cbd562a553e0c5aa1d0786b088f472cd7 SHA512 2895d86c62cb799302ba1515a3b638d52ca253f78e07bcc542bbb99338b84bc2079d48f42fb85a627e9252a545a853629943f9a904ead600aff161a24e1f1658
diff --git a/dev-libs/mxml/mxml-3.3.1.ebuild b/dev-libs/mxml/mxml-3.3.1.ebuild
new file mode 100644
index 000000000000..e7c70782ab52
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}