summaryrefslogtreecommitdiff
path: root/dev-libs/mpfr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/mpfr
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/Manifest2
-rw-r--r--dev-libs/mpfr/mpfr-4.1.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/mpfr/Manifest b/dev-libs/mpfr/Manifest
index 1092d8a3cf03..1c171764397c 100644
--- a/dev-libs/mpfr/Manifest
+++ b/dev-libs/mpfr/Manifest
@@ -1,3 +1,5 @@
DIST mpfr-4.0.2.tar.xz 1441996 BLAKE2B 4c1a15208c2dc3dcc1424974de506198e9cc479c70255149876c7f541133499ada5c89f07393b120b7079e6bbaf8ea03e5e496e1350b295e687392a6e0341c1c SHA512 d583555d08863bf36c89b289ae26bae353d9a31f08ee3894520992d2c26e5683c4c9c193d7ad139632f71c0a476d85ea76182702a98bf08dde7b6f65a54f8b88
+DIST mpfr-4.1.0.tar.xz 1525476 BLAKE2B 41d1be0c4b557760f12a4525ad3a84b6e2cd6f0927c935fcfba577ac0490e582d1ae4b581dce58e21e705cf9d7c88373054d7fb7a94bb32c69b339f99a25dc68 SHA512 1bd1c349741a6529dfa53af4f0da8d49254b164ece8a46928cdb13a99460285622d57fe6f68cef19c6727b3f9daa25ddb3d7d65c201c8f387e421c7f7bee6273
EBUILD mpfr-4.0.2.ebuild 1644 BLAKE2B 0e93bbe9c14f289fad63c5055eaee18299d4daa1297581f2bf8241e75ef711814de09a6ce6154bb1979b6e452c674d6a5a59289deb8b134752c4bf9fdc35c7d9 SHA512 7ef27262e6172f59c952e61f5b2433225066778a3b7a7d3114542dc8356de625e4a59361c0606d302250c28c23ea565990b70eb139a9d0633475d9d8071de328
+EBUILD mpfr-4.1.0.ebuild 1062 BLAKE2B 7f987a8cfddc96a4f8308a23044f22ea587c48139fa85a8cac2646098f5f302a7de14f5e23398702b18ed93aa170dbc365eb2bc62d91ff7976ec6437557956e9 SHA512 3a57ccd9abd0527be30986c5114ed9fba34ae19c0387508541d3a7daee8ee65706003b3cc623f8f8a4fa9ed3136f433ca9fba00068d99dc36ec39b378910b797
MISC metadata.xml 257 BLAKE2B 468bd91200194cf2104205cb18f54d629954ed0d86d85a5d3e90af1942eb199d777a0ebc17d1f610f69326d3e0caa686255709f165466f5e0a675380373b30f9 SHA512 fd85d9cf15f6b7db96e4d184e32ae6f1503a5b70cb4cb1ce930ba13a1d5d4c4b24971781e95b7f3f9ead58b31760f84c368bc6fa2a793b4b5baf78259b047ff1
diff --git a/dev-libs/mpfr/mpfr-4.1.0.ebuild b/dev-libs/mpfr/mpfr-4.1.0.ebuild
new file mode 100644
index 000000000000..8ae3c247d9c2
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="https://www.mpfr.org/"
+SRC_URI="https://www.mpfr.org/mpfr-${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # libmpfr.so version
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.0.0[${MULTILIB_USEDEP},static-libs?]"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/FAQ.html )
+
+multilib_src_configure() {
+ # Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
+ ECONF_SOURCE=${S} \
+ user_redefine_cc=yes \
+ econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ rm "${ED}"/usr/share/doc/"${P}"/COPYING*
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}