summaryrefslogtreecommitdiff
path: root/dev-libs/mpfr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 00:57:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 00:57:34 +0000
commit6330245077f9f298a785e17756a8f59a843361a5 (patch)
tree5230e465e0b66c66bfec278f434599739f6a7417 /dev-libs/mpfr
parent0a610f61a00066203da0b0ed9ba215efbb480f4f (diff)
gentoo auto-resync : 18:11:2022 - 00:57:34
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/Manifest2
-rw-r--r--dev-libs/mpfr/mpfr-4.1.1.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/mpfr/Manifest b/dev-libs/mpfr/Manifest
index 426eddb318d2..7f0335c23961 100644
--- a/dev-libs/mpfr/Manifest
+++ b/dev-libs/mpfr/Manifest
@@ -12,5 +12,7 @@ DIST mpfr-4.1.0-patch11.patch 4584 BLAKE2B 4ba240e7e8acc360eb2f05186493fd9044c8f
DIST mpfr-4.1.0-patch12.patch 6768 BLAKE2B 15ce68eb9941ac5d6544ee18a062cb12026e07273a5424b3941596a1024f54cf5481363e145cac9375e518ec2033db82d4fe9152884c74a9037a81fd2c405b5e SHA512 4e91cffa0df911d68931ace13e86e420ec9f7d8e8a0279e12d995bbf8061b6bec90cb03ef8642a854f652907b13e533b7afb95f2279cf2dfa4010ec5d745ac3c
DIST mpfr-4.1.0-patch13.patch 3344 BLAKE2B 1239cf16dfe32a71bb6fc7b156978cd451bcbe4e1b04842fdb3549352a43607d44d58120e38bf448ffd33e36bab7f7cfd4ab65b2eb3aac2fe9bbd86d8f425f5a SHA512 ddd5f54d12584b6e10fd4eba12b8568c5286dba10bd3b5cdd429415b78bc827bd0ed3957bd06ca4c2c63a2f5e877fd9d86eebade8929d61aafe84ace8454d016
DIST mpfr-4.1.0.tar.xz 1525476 BLAKE2B 41d1be0c4b557760f12a4525ad3a84b6e2cd6f0927c935fcfba577ac0490e582d1ae4b581dce58e21e705cf9d7c88373054d7fb7a94bb32c69b339f99a25dc68 SHA512 1bd1c349741a6529dfa53af4f0da8d49254b164ece8a46928cdb13a99460285622d57fe6f68cef19c6727b3f9daa25ddb3d7d65c201c8f387e421c7f7bee6273
+DIST mpfr-4.1.1.tar.xz 1429836 BLAKE2B ce20baee2f060acb28b877ffe6fc40c5619cf6af231bd54ca6cfb3e42ef2d74a4ffbab96cf0b5dd6a162e558099a54701d42f34f5bf2256f256fe6f5ae2505d0 SHA512 be468749bd88870dec37be35e544983a8fb7bda638eb9414c37334b9d553099ea2aa067045f51ae2c8ab86d852ef833e18161d173e414af0928e9a438c9b91f1
EBUILD mpfr-4.1.0_p13-r1.ebuild 2700 BLAKE2B 46afea4da633c055ece8404cfabe6171abb568061a33445a58a961b55a3eb23ed28f08011efc001de2fdccc79c3ab34cc2d798be48928b74d2d1a302b8273cf2 SHA512 2e088ffc2e2343d8ce54b62ff625df579ea9236e31981f893c478f1e2b14e19d3bfa332d98fe9c486793a23acf76b231abf8ada2c1f4e7319bafa9ace3daf2fa
+EBUILD mpfr-4.1.1.ebuild 2708 BLAKE2B ad21498526dd91dcc6d03b35153cbd284d85d1ee90515ab3e323a3e9c44a16ce4b8bdc59c590b5b0b7166d1a3f8fc86f42fa5b72bab7fa7e3df72e7bba3586a5 SHA512 d08c80ed13fad11c6469812d1ba9aa1074ecb27707469c1ea368e77fc9d9d5d09511c205490f97450f0c4114ac09fed53a9170259ba66f82eea949c10b0ae42f
MISC metadata.xml 344 BLAKE2B b7a0bcfbcf945ce2b6d58a9a2078c823c12de5ef8261ec009612b58a833deecb7caaf864f0b55e0c46aac004c58feb7a1f88f6d78b584c2e25c403cfb1de96a0 SHA512 8b8b5ae00a4f9ba76c193c5d84f27cce973963f4db109219394efccba3a8e8bebb7f241658a0b682331e34c66ee99332f871d826abf6ec5a4ced4f3dce381fe9
diff --git a/dev-libs/mpfr/mpfr-4.1.1.ebuild b/dev-libs/mpfr/mpfr-4.1.1.ebuild
new file mode 100644
index 000000000000..13392ae4cf60
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-4.1.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+# Upstream distribute patches before a new release is made
+# See https://www.mpfr.org/mpfr-current/#bugs for the latest version (and patches)
+
+# Check whether any patches touch e.g. manuals!
+# https://archives.gentoo.org/gentoo-releng-autobuilds/message/c2dd39fc4ebc849db6bb0f551739e2ed
+MY_PV=$(ver_cut 1-3)
+MY_PATCH=$(ver_cut 5-)
+MY_PATCHES=()
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="https://www.mpfr.org/ https://gitlab.inria.fr/mpfr"
+SRC_URI="https://www.mpfr.org/${MY_P}/${MY_P}.tar.xz"
+if [[ ${PV} == *_p* ]] ; then
+ # If this is a patch release, we have to download each of the patches:
+ # -_pN = N patches
+ # - patch file names are like: patch01, patch02, ..., patch10, patch12, ..
+ #
+ # => name the ebuild _pN where N is the number of patches on the 'bugs' page.
+ for ((my_patch_index=1; my_patch_index <= MY_PATCH; my_patch_index++)); do
+ SRC_URI+=" $(printf "https://www.mpfr.org/${MY_P}/patch%02d -> ${MY_P}-patch%02d.patch " ${my_patch_index}{,})"
+ MY_PATCHES+=( "${DISTDIR}"/$(printf ${MY_P}-patch%02d.patch ${my_patch_index}) )
+ done
+ unset my_patch_index
+fi
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+# This is a critical package; if SONAME changes, bump subslot but also add
+# preserve-libs.eclass usage to pkg_*inst! See e.g. the readline ebuild.
+SLOT="0/6" # libmpfr.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.0.0:=[${MULTILIB_USEDEP},static-libs?]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Apply the upstream patches released out-of-band; generated above
+ "${MY_PATCHES[@]}"
+
+ # Additional patches
+)
+
+HTML_DOCS=( doc/FAQ.html )
+
+src_unpack() {
+ # Avoid src_unpack noise from patches
+ unpack ${MY_P}.tar.xz
+}
+
+src_prepare() {
+ default
+
+ # 4.1.0_p13's patch10 patches a .texi file *and* the corresponding
+ # info file. We need to make sure the info file is newer, so the
+ # build doesn't try to run makeinfo. Won't be needed on next release.
+ touch "${S}/doc/mpfr.info" || die
+}
+
+multilib_src_configure() {
+ # bug #476336#19
+ # Make sure mpfr doesn't go probing toolchains it shouldn't
+ ECONF_SOURCE="${S}" \
+ user_redefine_cc=yes \
+ econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ rm "${ED}"/usr/share/doc/${PF}/COPYING* || die
+
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
+}