summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild')
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
deleted file mode 100644
index 44af34364f24..000000000000
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.1.2-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="A high-performance MongoDB driver for C"
-HOMEPAGE="https://github.com/mongodb/mongo-c-driver"
-SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="debug examples libressl sasl ssl static-libs test"
-
-RDEPEND=">=dev-libs/libbson-1.0
- sasl? ( dev-libs/cyrus-sasl )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${RDEPEND}
- test? ( dev-db/mongodb )"
-
-DOCS=( NEWS README.rst TUTORIAL.md )
-
-src_prepare() {
- rm -r src/libbson || die
- sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
-
- # https://github.com/mongodb/mongo-c-driver/issues/54
- sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/Makefile.am \
- tests/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- econf --with-libbson=system \
- --disable-hardening \
- --disable-optimizations \
- --disable-examples \
- $(use_enable sasl) \
- $(use_enable ssl) \
- $(use_enable debug) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- doman doc/*.3
-
- use static-libs || find "${D}" -name '*.la' -delete
-
- if use examples; then
- insinto /usr/share/${PF}/examples
- doins -r examples/*.c examples/aggregation examples/bulk
- fi
-}
-
-src_test() {
- # Avoid allocating too much disk space by using server.smallFiles = 1
- echo -e "storage:\n smallFiles: true" > "${T}/mongod.conf"
- local PORT=27099
- mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
- -f "${T}/mongod.conf" --dbpath="${T}" \
- --logpath="${T}/mongod.log" || die
- MONGOC_TEST_HOST="127.0.0.1:${PORT}" emake test
- kill `cat "${T}/mongod.lock"`
-}