summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-libs/mongo-c-driver/files
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-libs/mongo-c-driver/files')
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-enable-tests.patch25
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-no-uninstall.patch27
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-enable-tests.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-enable-tests.patch
new file mode 100644
index 000000000000..983e025b9170
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-enable-tests.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 22d1f4f..8ab33c6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -118,7 +118,6 @@ if (ENABLE_BSON STREQUAL SYSTEM)
+ message ("-- libbson include path \"${BSON_INCLUDE_DIRS}\"")
+ message ("-- libbson libraries \"${BSON_LIBRARIES}\"")
+ message ("-- disabling test-libmongoc since using system libbson")
+- SET (ENABLE_TESTS OFF)
+
+ if (ENABLE_STATIC MATCHES "ON|AUTO")
+ find_package (libbson-static-1.0
+diff --git a/src/libbson/tests/test-bson.c b/src/libbson/tests/test-bson.c
+index 6ac94f3..cec430f 100644
+--- a/src/libbson/tests/test-bson.c
++++ b/src/libbson/tests/test-bson.c
+@@ -18,7 +18,7 @@
+ #include <bson/bson.h>
+ #include <bson/bcon.h>
+ #define BSON_INSIDE
+-#include <bson/bson-private.h>
++#include "bson/bson-private.h"
+ #undef BSON_INSIDE
+ #include <fcntl.h>
+ #include <time.h>
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-no-uninstall.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-no-uninstall.patch
new file mode 100644
index 000000000000..64a90bbe3ece
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.13.0-no-uninstall.patch
@@ -0,0 +1,27 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f7a0dfe..22d1f4f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -271,7 +271,6 @@ if (ENABLE_MONGOC)
+ VERSION_CURRENT
+ VERSION_RELEASED
+ # This sub-directory is added later, so manually include here
+- generate_uninstall/CMakeLists.txt
+ )
+
+ set_local_dist (top_DIST ${top_DIST_local})
+@@ -341,14 +340,8 @@ if (WIN32)
+ else ()
+ set (UNINSTALL_PROG "uninstall.sh")
+ endif ()
+-set (UNINSTALL_PROG_DIR "${CMAKE_INSTALL_FULL_DATADIR}/mongo-c-driver")
+
+ # Create uninstall program and associated uninstall target
+ #
+ # This needs to be last (after all other add_subdirectory calls) to ensure that
+ # the generated uninstall program is complete and correct
+-add_subdirectory (generate_uninstall)
+-
+-add_custom_target (uninstall
+- COMMAND "${UNINSTALL_PROG_DIR}/${UNINSTALL_PROG}"
+-)