summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/mongo-c-driver/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/mongo-c-driver/files')
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-enable-tests.patch25
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-no-docs.patch15
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-enable-tests.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-enable-tests.patch
new file mode 100644
index 000000000000..76202b5e387a
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-enable-tests.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c0e01a8..3371dae 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -163,7 +163,6 @@ if (ENABLE_BSON STREQUAL SYSTEM)
+ message ("-- libbson include path \"${BSON_INCLUDE_DIRS}\"")
+ message ("-- libbson libraries \"${BSON_LIBRARIES}\"")
+ message ("-- disabling test-libmongoc since using system libbson")
+- SET (ENABLE_TESTS OFF)
+
+ if (ENABLE_STATIC MATCHES "ON|AUTO")
+ find_package (libbson-static-1.0
+diff --git a/src/libbson/tests/test-bson.c b/src/libbson/tests/test-bson.c
+index 95356fa..9f9aea3 100644
+--- a/src/libbson/tests/test-bson.c
++++ b/src/libbson/tests/test-bson.c
+@@ -17,7 +17,7 @@
+
+ #include <bson/bson.h>
+ #include <bson/bcon.h>
+-#include <bson/bson-private.h>
++#include "bson/bson-private.h"
+ #include <fcntl.h>
+ #include <time.h>
+
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-no-docs.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-no-docs.patch
new file mode 100644
index 000000000000..d33fba105ab0
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.14.0-no-docs.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3371dae..a6edf0f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -380,10 +380,6 @@ if (ENABLE_MONGOC)
+
+ endif ()
+
+-install (FILES COPYING NEWS README.rst THIRD_PARTY_NOTICES
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/mongo-c-driver
+-)
+-
+ if (ENABLE_UNINSTALL)
+ if (WIN32)
+ if (ENABLE_MONGOC)