summaryrefslogtreecommitdiff
path: root/dev-libs/mongo-c-driver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/mongo-c-driver/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/mongo-c-driver/files')
-rw-r--r--dev-libs/mongo-c-driver/files/0.8.1-api-version.diff14
-rw-r--r--dev-libs/mongo-c-driver/files/mongo-c-driver-1.10.3-enable-tests.patch25
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff b/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff
new file mode 100644
index 000000000000..2bd52253a17b
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/0.8.1-api-version.diff
@@ -0,0 +1,14 @@
+diff -uNr mongo-c-driver-0.8.1.ORIG/src/mongo.h mongo-c-driver-0.8.1/src/mongo.h
+--- mongo-c-driver-0.8.1.ORIG/src/mongo.h 2014-03-27 17:00:42.880465606 +0000
++++ mongo-c-driver-0.8.1/src/mongo.h 2014-03-27 17:01:05.131465940 +0000
+@@ -33,8 +33,8 @@
+ #endif
+
+ #define MONGO_MAJOR 0
+-#define MONGO_MINOR 7
+-#define MONGO_PATCH 0
++#define MONGO_MINOR 8
++#define MONGO_PATCH 1
+
+ #define MONGO_OK 0
+ #define MONGO_ERROR -1
diff --git a/dev-libs/mongo-c-driver/files/mongo-c-driver-1.10.3-enable-tests.patch b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.10.3-enable-tests.patch
new file mode 100644
index 000000000000..af26b6953139
--- /dev/null
+++ b/dev-libs/mongo-c-driver/files/mongo-c-driver-1.10.3-enable-tests.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2eeb6cb..aeaa23b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -109,7 +109,6 @@ if (ENABLE_BSON STREQUAL SYSTEM)
+ message ("-- libbson include path \"${BSON_INCLUDE_DIRS}\"")
+ message ("-- libbson libraries \"${BSON_LIBRARIES}\"")
+ message ("-- disabling test-libmongoc since using system libbson")
+- SET (ENABLE_TESTS OFF)
+
+ if (ENABLE_STATIC MATCHES "ON|AUTO")
+ find_package (libbson-static-1.0
+diff --git a/src/libbson/tests/test-bson.c b/src/libbson/tests/test-bson.c
+index 51514ed..accb251 100644
+--- a/src/libbson/tests/test-bson.c
++++ b/src/libbson/tests/test-bson.c
+@@ -18,7 +18,7 @@
+ #include <bson.h>
+ #include <bcon.h>
+ #define BSON_INSIDE
+-#include <bson-private.h>
++#include "bson-private.h"
+ #undef BSON_INSIDE
+ #include <fcntl.h>
+ #include <time.h>