summaryrefslogtreecommitdiff
path: root/dev-libs/mimetic/mimetic-0.9.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/mimetic/mimetic-0.9.8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/mimetic/mimetic-0.9.8.ebuild')
-rw-r--r--dev-libs/mimetic/mimetic-0.9.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/mimetic/mimetic-0.9.8.ebuild b/dev-libs/mimetic/mimetic-0.9.8.ebuild
new file mode 100644
index 000000000000..ffa4669138a1
--- /dev/null
+++ b/dev-libs/mimetic/mimetic-0.9.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="C++ MIME library designed to be easy to use and integrate, fast and efficient."
+HOMEPAGE="http://www.codesink.org/mimetic_mime_library.html"
+SRC_URI="http://www.codesink.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ sed -i -e "s|../doxygen.css|doxygen.css|" doc/header.html || die
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html/
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
+ fi
+
+ rm "${D}"/usr/$(get_libdir)/libmimetic.la || die
+}