summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
commit84dcbb8bcdcf5785ac3b24905c73ae4aa6bb781e (patch)
tree6f6b979013e5661ca4b3690bc9417307fdc169ce /dev-libs/mimalloc/mimalloc-2.0.7.ebuild
parent57e62db33bb33adb6593a2be7b3a5990aaf01f56 (diff)
gentoo auto-resync : 16:11:2022 - 00:53:49
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.0.7.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.0.7.ebuild b/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
new file mode 100644
index 000000000000..313ecbb034c5
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="hardened test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}