summaryrefslogtreecommitdiff
path: root/dev-libs/luise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/luise
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/luise')
-rw-r--r--dev-libs/luise/Manifest3
-rw-r--r--dev-libs/luise/luise-0.1.1-r1.ebuild39
-rw-r--r--dev-libs/luise/metadata.xml21
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/luise/Manifest b/dev-libs/luise/Manifest
new file mode 100644
index 000000000000..5e76b7c7174c
--- /dev/null
+++ b/dev-libs/luise/Manifest
@@ -0,0 +1,3 @@
+DIST LUIse_0.1.1.tar.gz 393815 BLAKE2B be7e35e1f4d5f6227f92bfeb5ed414593215c194e8d7ab67036ac7316cf6faeada839bbef15d8569b6fc276f3bddf41bdaf66e7315f6e8ff1341f8d697327895 SHA512 821b62ed476088c3818cb478a3c525e1d92e9879ef4059da0eb534852a294f802550ad7169066fe439f0cb3645e98656f405594db633061029ae9d7eff86f31d
+EBUILD luise-0.1.1-r1.ebuild 1009 BLAKE2B 1c81be489b57c112edd0e3f79be2ea1c3abc622f2cfd3f5b91f16ebcdb3d4d0dad3b94bdce042ef376cef69c6cfa2835d06b01c9f7ec9a1e70ed0d3bc5b8a28c SHA512 306d1290a780dfa5f79a95e4f28ad0ff9c2323f555d451a880173b21ff42b00ef3c26a8382ac32d0478dfcc1b53d4e2d284dca9615838989a96215b879da285f
+MISC metadata.xml 1194 BLAKE2B 9205382d50d4a6c64f752dfcf4d7c22b8f581dacb7724ecd4255949a843e0fe07b9550f16e75ba8b8305faa3df6942fb532887a62715999d9b151e8c660a1961 SHA512 ad7ed0c143e0efb40eefdcec9d83bb0851f16a4815b2cb2acf1aaf8595a39727d375d4f34c3c9f772df1d31e47a779e91a2f9297c42bbd7bcf540afbb087704e
diff --git a/dev-libs/luise/luise-0.1.1-r1.ebuild b/dev-libs/luise/luise-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..2653ebe53508
--- /dev/null
+++ b/dev-libs/luise/luise-0.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="LUIse"
+
+inherit multilib
+
+DESCRIPTION="Programming interface for the Wallbraun LCD-USB-Interface"
+HOMEPAGE="https://web.archive.org/web/20140102061822/http://wallbraun-electronics.de/"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="examples"
+
+RDEPEND="virtual/libusb:0"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+QA_PREBUILT="
+ usr/lib/libluise.so.${PV}
+ usr/lib64/libluise.so.${PV}
+"
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ newins $(usex amd64 '64' '32')bit/libluise$(usex amd64 '_64' '').so.${PV} libluise.so.${PV}
+ dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so.${SLOT}
+ dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so
+
+ insinto /usr/include
+ doins $(usex amd64 '64' '32')bit/luise.h
+
+ dodoc doc/*
+ use examples && dodoc -r samples/luise-test
+}
diff --git a/dev-libs/luise/metadata.xml b/dev-libs/luise/metadata.xml
new file mode 100644
index 000000000000..2b9a35f1422c
--- /dev/null
+++ b/dev-libs/luise/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ The libluise.so lib provides a very simple interface for programming
+ the USB LCDs ready. The programmer has three independent screens available,
+ a text screen and two graphic screens. The screens are each 320x240 pixels.
+ By the two separate graphic screens can be very easily superimposed static and
+ represent dynamic data. This is for example when using background images
+ helpful because the environment of the dynamic data / graphics is not constantly recalculated
+ got to. All three screens will appear "on top of each other" on the LCD and will go through
+ previously defined parameters (LUI_LCDmode ()) corresponding to each other bitwise
+ connected. The coordinate origin (x = 0, y = 0) of a screen is always in the
+ left upper corner. In addition, the inversion and the rotation of the screens
+ supports (90 ° steps), while saving the programmer the coordinates conversions stay.
+ </longdescription>
+</pkgmetadata>