summaryrefslogtreecommitdiff
path: root/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-libs/libxmlb/libxmlb-0.1.11.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-libs/libxmlb/libxmlb-0.1.11.ebuild')
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.11.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.1.11.ebuild b/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
index 487a34f0da43..51a1b304f84c 100644
--- a/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.1.11.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit meson python-any-r1
DESCRIPTION="Library to help create and query binary XML blobs"
HOMEPAGE="https://github.com/hughsie/libxmlb"
@@ -29,8 +31,20 @@ DEPEND="
BDEPEND="
>=dev-util/meson-0.47.0
virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ )
"
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
src_configure() {
local emesonargs=(
-Dgtkdoc="$(usex doc true false)"