summaryrefslogtreecommitdiff
path: root/dev-libs/libxml2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
commit24c53d42e0294f4f6e36fbb051891af86c9ae503 (patch)
treeb0af743b9df96807807fc6a16e77af239820b0c3 /dev-libs/libxml2/files
parent351b26cfd42c558fa0f8eef51960c87bb0674026 (diff)
gentoo auto-resync : 23:05:2023 - 02:57:53
Diffstat (limited to 'dev-libs/libxml2/files')
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch63
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch27
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch245
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch27
-rw-r--r--dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch21
5 files changed, 0 insertions, 383 deletions
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch
deleted file mode 100644
index 615f413c4419..000000000000
--- a/dev-libs/libxml2/files/libxml2-2.11.2-0001-iconv.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-https://gitlab.gnome.org/GNOME/libxml2/-/commit/9c1f5fe7fbad2b57149c628802c4ded3e4f3d284
-
-From 9c1f5fe7fbad2b57149c628802c4ded3e4f3d284 Mon Sep 17 00:00:00 2001
-From: Mike Dalessio <mike.dalessio@gmail.com>
-Date: Fri, 5 May 2023 17:34:57 -0400
-Subject: [PATCH] autoconf: fix iconv library paths
-
-and pass cflags when building executables
-
-See 0f77167f for prior related work
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -145,11 +145,12 @@ runsuite_DEPENDENCIES = $(DEPS)
- runsuite_LDADD= $(LDADDS)
-
- xmllint_SOURCES=xmllint.c
--xmllint_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS)
-+xmllint_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS) $(ICONV_CFLAGS)
- xmllint_DEPENDENCIES = $(DEPS)
- xmllint_LDADD= $(RDL_LIBS) $(LDADDS)
-
- xmlcatalog_SOURCES=xmlcatalog.c
-+xmlcatalog_CFLAGS = $(AM_CFLAGS) $(RDL_CFLAGS) $(ICONV_CFLAGS)
- xmlcatalog_DEPENDENCIES = $(DEPS)
- xmlcatalog_LDADD = $(RDL_LIBS) $(LDADDS)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1036,7 +1036,7 @@ else
- if test "$with_iconv" != "yes" && test "$with_iconv" != "" ; then
- ICONV_DIR=$with_iconv
- CPPFLAGS="$CPPFLAGS -I$ICONV_DIR/include"
-- LIBS="$LIBS -L$ICONV_DIR/libs"
-+ LIBS="$LIBS -L$ICONV_DIR/lib"
- # Export this since our headers include iconv.h
- XML_INCLUDEDIR="$XML_INCLUDEDIR -I$ICONV_DIR/include"
- fi
-@@ -1052,12 +1052,13 @@ else
- ICONV_LIBS="-liconv"])])])
- if test "$WITH_ICONV" = "1" && test "$ICONV_DIR" != ""; then
- ICONV_CFLAGS="-I$ICONV_DIR/include"
-- ICONV_LIBS="-L$ICONV_DIR/libs $ICONV_LIBS"
-+ ICONV_LIBS="-L$ICONV_DIR/lib $ICONV_LIBS"
- fi
- CPPFLAGS=$_cppflags
- LIBS=$_libs
- fi
- AC_SUBST(WITH_ICONV)
-+AC_SUBST(ICONV_CFLAGS)
-
- dnl
- dnl Checks for ICU library.
-@@ -1100,7 +1101,7 @@ else
- ICU_LIBS=-licucore
- if test "$ICU_DIR" != ""; then
- ICU_CFLAGS="-I$ICU_DIR/include"
-- ICU_LIBS="-L$ICU_DIR/libs $ICU_LIBS"
-+ ICU_LIBS="-L$ICU_DIR/lib $ICU_LIBS"
- fi])])
- CPPFLAGS=$_cppflags
- LIBS=$_libs
---
-GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch
deleted file mode 100644
index 2253ea6211d1..000000000000
--- a/dev-libs/libxml2/files/libxml2-2.11.2-0002-crash-old-libxslt.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://gitlab.gnome.org/GNOME/libxml2/-/commit/e6a9cc8d66778c20435a46e50d4e5866deace5f6
-
-From e6a9cc8d66778c20435a46e50d4e5866deace5f6 Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Sat, 6 May 2023 15:28:13 +0200
-Subject: [PATCH] hash: Fix possible startup crash with old libxslt versions
-
-Call xmlInitParser in xmlHashCreate to make it work if the library
-wasn't initialized yet.
-
-Otherwise, exsltRegisterAll from libxslt 1.1.24 or older might cause
-a crash.
-
-See #534.
---- a/hash.c
-+++ b/hash.c
-@@ -180,6 +180,8 @@ xmlHashTablePtr
- xmlHashCreate(int size) {
- xmlHashTablePtr table;
-
-+ xmlInitParser();
-+
- if (size <= 0)
- size = 256;
-
---
-GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch
deleted file mode 100644
index f036c5814f26..000000000000
--- a/dev-libs/libxml2/files/libxml2-2.11.2-0003-no-xpath.patch
+++ /dev/null
@@ -1,245 +0,0 @@
-https://gitlab.gnome.org/GNOME/libxml2/-/commit/41e78f8f8656b8e2206c06995da6bd8dcc82823d
-
-From 41e78f8f8656b8e2206c06995da6bd8dcc82823d Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Mon, 8 May 2023 23:12:33 +0200
-Subject: [PATCH] xpath: Fix build without LIBXML_XPATH_ENABLED
-
-Move static function declaration into XPATH block. Also move comparison
-functions.
-
-Fixes #537.
---- a/xpath.c
-+++ b/xpath.c
-@@ -145,6 +145,114 @@
- * any use of the macros IS_ASCII_CHARACTER and IS_ASCII_DIGIT)
- */
-
-+#if defined(LIBXML_XPATH_ENABLED) || defined(LIBXML_SCHEMAS_ENABLED)
-+
-+/************************************************************************
-+ * *
-+ * Floating point stuff *
-+ * *
-+ ************************************************************************/
-+
-+double xmlXPathNAN = 0.0;
-+double xmlXPathPINF = 0.0;
-+double xmlXPathNINF = 0.0;
-+
-+/**
-+ * xmlXPathInit:
-+ *
-+ * DEPRECATED: Alias for xmlInitParser.
-+ */
-+void
-+xmlXPathInit(void) {
-+ xmlInitParser();
-+}
-+
-+/**
-+ * xmlInitXPathInternal:
-+ *
-+ * Initialize the XPath environment
-+ */
-+ATTRIBUTE_NO_SANITIZE("float-divide-by-zero")
-+void
-+xmlInitXPathInternal(void) {
-+#if defined(NAN) && defined(INFINITY)
-+ xmlXPathNAN = NAN;
-+ xmlXPathPINF = INFINITY;
-+ xmlXPathNINF = -INFINITY;
-+#else
-+ /* MSVC doesn't allow division by zero in constant expressions. */
-+ double zero = 0.0;
-+ xmlXPathNAN = 0.0 / zero;
-+ xmlXPathPINF = 1.0 / zero;
-+ xmlXPathNINF = -xmlXPathPINF;
-+#endif
-+}
-+
-+/**
-+ * xmlXPathIsNaN:
-+ * @val: a double value
-+ *
-+ * Returns 1 if the value is a NaN, 0 otherwise
-+ */
-+int
-+xmlXPathIsNaN(double val) {
-+#ifdef isnan
-+ return isnan(val);
-+#else
-+ return !(val == val);
-+#endif
-+}
-+
-+/**
-+ * xmlXPathIsInf:
-+ * @val: a double value
-+ *
-+ * Returns 1 if the value is +Infinite, -1 if -Infinite, 0 otherwise
-+ */
-+int
-+xmlXPathIsInf(double val) {
-+#ifdef isinf
-+ return isinf(val) ? (val > 0 ? 1 : -1) : 0;
-+#else
-+ if (val >= xmlXPathPINF)
-+ return 1;
-+ if (val <= -xmlXPathPINF)
-+ return -1;
-+ return 0;
-+#endif
-+}
-+
-+#endif /* SCHEMAS or XPATH */
-+
-+#ifdef LIBXML_XPATH_ENABLED
-+
-+/*
-+ * TODO: when compatibility allows remove all "fake node libxslt" strings
-+ * the test should just be name[0] = ' '
-+ */
-+#ifdef DEBUG_XPATH_EXPRESSION
-+#define DEBUG_STEP
-+#define DEBUG_EXPR
-+#define DEBUG_EVAL_COUNTS
-+#endif
-+
-+static xmlNs xmlXPathXMLNamespaceStruct = {
-+ NULL,
-+ XML_NAMESPACE_DECL,
-+ XML_XML_NAMESPACE,
-+ BAD_CAST "xml",
-+ NULL,
-+ NULL
-+};
-+static xmlNsPtr xmlXPathXMLNamespace = &xmlXPathXMLNamespaceStruct;
-+#ifndef LIBXML_THREAD_ENABLED
-+/*
-+ * Optimizer is disabled only when threaded apps are detected while
-+ * the library ain't compiled for thread safety.
-+ */
-+static int xmlXPathDisableOptimizer = 0;
-+#endif
-+
- static void
- xmlXPathNodeSetClear(xmlNodeSetPtr set, int hasNsNodes);
-
-@@ -475,114 +583,6 @@ int wrap_cmp( xmlNodePtr x, xmlNodePtr y );
- #include "timsort.h"
- #endif /* WITH_TIM_SORT */
-
--#if defined(LIBXML_XPATH_ENABLED) || defined(LIBXML_SCHEMAS_ENABLED)
--
--/************************************************************************
-- * *
-- * Floating point stuff *
-- * *
-- ************************************************************************/
--
--double xmlXPathNAN = 0.0;
--double xmlXPathPINF = 0.0;
--double xmlXPathNINF = 0.0;
--
--/**
-- * xmlXPathInit:
-- *
-- * DEPRECATED: Alias for xmlInitParser.
-- */
--void
--xmlXPathInit(void) {
-- xmlInitParser();
--}
--
--/**
-- * xmlInitXPathInternal:
-- *
-- * Initialize the XPath environment
-- */
--ATTRIBUTE_NO_SANITIZE("float-divide-by-zero")
--void
--xmlInitXPathInternal(void) {
--#if defined(NAN) && defined(INFINITY)
-- xmlXPathNAN = NAN;
-- xmlXPathPINF = INFINITY;
-- xmlXPathNINF = -INFINITY;
--#else
-- /* MSVC doesn't allow division by zero in constant expressions. */
-- double zero = 0.0;
-- xmlXPathNAN = 0.0 / zero;
-- xmlXPathPINF = 1.0 / zero;
-- xmlXPathNINF = -xmlXPathPINF;
--#endif
--}
--
--/**
-- * xmlXPathIsNaN:
-- * @val: a double value
-- *
-- * Returns 1 if the value is a NaN, 0 otherwise
-- */
--int
--xmlXPathIsNaN(double val) {
--#ifdef isnan
-- return isnan(val);
--#else
-- return !(val == val);
--#endif
--}
--
--/**
-- * xmlXPathIsInf:
-- * @val: a double value
-- *
-- * Returns 1 if the value is +Infinite, -1 if -Infinite, 0 otherwise
-- */
--int
--xmlXPathIsInf(double val) {
--#ifdef isinf
-- return isinf(val) ? (val > 0 ? 1 : -1) : 0;
--#else
-- if (val >= xmlXPathPINF)
-- return 1;
-- if (val <= -xmlXPathPINF)
-- return -1;
-- return 0;
--#endif
--}
--
--#endif /* SCHEMAS or XPATH */
--
--#ifdef LIBXML_XPATH_ENABLED
--
--/*
-- * TODO: when compatibility allows remove all "fake node libxslt" strings
-- * the test should just be name[0] = ' '
-- */
--#ifdef DEBUG_XPATH_EXPRESSION
--#define DEBUG_STEP
--#define DEBUG_EXPR
--#define DEBUG_EVAL_COUNTS
--#endif
--
--static xmlNs xmlXPathXMLNamespaceStruct = {
-- NULL,
-- XML_NAMESPACE_DECL,
-- XML_XML_NAMESPACE,
-- BAD_CAST "xml",
-- NULL,
-- NULL
--};
--static xmlNsPtr xmlXPathXMLNamespace = &xmlXPathXMLNamespaceStruct;
--#ifndef LIBXML_THREAD_ENABLED
--/*
-- * Optimizer is disabled only when threaded apps are detected while
-- * the library ain't compiled for thread safety.
-- */
--static int xmlXPathDisableOptimizer = 0;
--#endif
--
- /************************************************************************
- * *
- * Error handling routines *
---
-GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch
deleted file mode 100644
index 5f3d06038271..000000000000
--- a/dev-libs/libxml2/files/libxml2-2.11.2-0004-huge-push.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://gitlab.gnome.org/GNOME/libxml2/-/commit/7c14859d0779797a93ea75744266425028599944
-
-From 7c14859d0779797a93ea75744266425028599944 Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Tue, 9 May 2023 13:28:06 +0200
-Subject: [PATCH] parser: Fix "huge input lookup" error with push parser
-
-Fix parsing of larger documents without XML_PARSE_HUGE.
-
-Should fix #538.
---- a/parserInternals.c
-+++ b/parserInternals.c
-@@ -418,9 +418,10 @@ xmlParserShrink(xmlParserCtxtPtr ctxt) {
- xmlParserInputBufferPtr buf = in->buf;
- size_t used;
-
-- /* Don't shrink memory buffers. */
-+ /* Don't shrink pull parser memory buffers. */
- if ((buf == NULL) ||
-- ((buf->encoder == NULL) && (buf->readcallback == NULL)))
-+ ((ctxt->progressive == 0) &&
-+ (buf->encoder == NULL) && (buf->readcallback == NULL)))
- return;
-
- used = in->cur - in->base;
---
-GitLab
diff --git a/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch b/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch
deleted file mode 100644
index 6fffb156ea9c..000000000000
--- a/dev-libs/libxml2/files/libxml2-2.11.2-0005-icu-detection.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://gitlab.gnome.org/GNOME/libxml2/-/commit/55f221a4c57903ced5721008607d4133d6eb51cf
-
-From 55f221a4c57903ced5721008607d4133d6eb51cf Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Wed, 10 May 2023 18:13:47 +0200
-Subject: [PATCH] autotools: Fix ICU detection
-
-Fixes #540.
---- a/configure.ac
-+++ b/configure.ac
-@@ -1096,7 +1096,7 @@ else
- fi
-
- AC_CHECK_HEADER(unicode/ucnv.h, [
-- AC_CHECK_LIB([icucore], [uconv_open], [
-+ AC_CHECK_LIB([icucore], [ucnv_open], [
- WITH_ICU=1
- ICU_LIBS=-licucore
- if test "$ICU_DIR" != ""; then
---
-GitLab