summaryrefslogtreecommitdiff
path: root/dev-libs/libxls/libxls-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libxls/libxls-1.4.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libxls/libxls-1.4.0-r1.ebuild')
-rw-r--r--dev-libs/libxls/libxls-1.4.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libxls/libxls-1.4.0-r1.ebuild b/dev-libs/libxls/libxls-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..fd8b84de8c06
--- /dev/null
+++ b/dev-libs/libxls/libxls-1.4.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A library which can read Excel (xls) files"
+HOMEPAGE="http://libxls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/libxls/${P}.zip"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0/1" # libxlsreader.so.1
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT=test # test driver is missing
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-asprintf.patch
+ "${FILESDIR}"/${P}-infinite.patch
+)
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}