summaryrefslogtreecommitdiff
path: root/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild')
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
new file mode 100644
index 000000000000..812f3cdac1fc
--- /dev/null
+++ b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Small library to access XDG Base Directories Specification paths"
+HOMEPAGE="https://github.com/devnev/libxdg-basedir"
+SRC_URI="https://github.com/devnev/libxdg-basedir/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-solaris"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc doxygen-html)
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ emake doxygen-doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}