summaryrefslogtreecommitdiff
path: root/dev-libs/libvformat/libvformat-1.13-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libvformat/libvformat-1.13-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libvformat/libvformat-1.13-r2.ebuild')
-rw-r--r--dev-libs/libvformat/libvformat-1.13-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libvformat/libvformat-1.13-r2.ebuild b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
new file mode 100644
index 000000000000..45b7ef932415
--- /dev/null
+++ b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Library to read and write vcard files"
+HOMEPAGE="https://sourceforge.net/projects/vformat/"
+SRC_URI="
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/libv/${PN}/${PN}_${PV}-10.debian.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/${P}.orig"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/*.patch \
+ "${FILESDIR}"/${PN}-nodoc.patch \
+ "${FILESDIR}"/${P}-has_unistd.patch \
+ "${FILESDIR}"/${P}-str.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}