summaryrefslogtreecommitdiff
path: root/dev-libs/libvformat/libvformat-1.13-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/libvformat/libvformat-1.13-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/libvformat/libvformat-1.13-r2.ebuild')
-rw-r--r--dev-libs/libvformat/libvformat-1.13-r2.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-libs/libvformat/libvformat-1.13-r2.ebuild b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
index 22f1d04278fc..323b1ec0b2de 100644
--- a/dev-libs/libvformat/libvformat-1.13-r2.ebuild
+++ b/dev-libs/libvformat/libvformat-1.13-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="Library to read and write vcard files"
HOMEPAGE="https://sourceforge.net/projects/vformat/"
@@ -10,29 +11,30 @@ SRC_URI="
mirror://debian/pool/main/libv/${PN}/${PN}_${PV}.orig.tar.gz
mirror://debian/pool/main/libv/${PN}/${PN}_${PV}-10.debian.tar.gz
"
+S="${WORKDIR}/${P}.orig"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
-IUSE="static-libs"
-
-S="${WORKDIR}/${P}.orig"
src_prepare() {
- epatch \
+ eapply \
"${WORKDIR}"/debian/patches/*.patch \
"${FILESDIR}"/${PN}-nodoc.patch \
"${FILESDIR}"/${P}-has_unistd.patch \
"${FILESDIR}"/${P}-str.patch
+ default
+
eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
default
- use static-libs || prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
}