summaryrefslogtreecommitdiff
path: root/dev-libs/libverto/libverto-0.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libverto/libverto-0.2.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libverto/libverto-0.2.5-r1.ebuild')
-rw-r--r--dev-libs/libverto/libverto-0.2.5-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libverto/libverto-0.2.5-r1.ebuild b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..c74a73291691
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib-minimal
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ libev? ( >=dev-libs/libev-4.15[${MULTILIB_USEDEP}] )
+ libevent? ( >=dev-libs/libevent-2.0.21[${MULTILIB_USEDEP}] )
+ tevent? ( >=sys-libs/tevent-0.9.19[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+ use static-libs || prune_libtool_files --all
+}