summaryrefslogtreecommitdiff
path: root/dev-libs/libverto/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-libs/libverto/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-libs/libverto/files')
-rw-r--r--dev-libs/libverto/files/libverto-Wflags.patch25
-rw-r--r--dev-libs/libverto/files/libverto-libev-c89.patch15
-rw-r--r--dev-libs/libverto/files/libverto-load.patch78
-rw-r--r--dev-libs/libverto/files/libverto-verify-cflags.patch26
4 files changed, 0 insertions, 144 deletions
diff --git a/dev-libs/libverto/files/libverto-Wflags.patch b/dev-libs/libverto/files/libverto-Wflags.patch
deleted file mode 100644
index de403720dd62..000000000000
--- a/dev-libs/libverto/files/libverto-Wflags.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f3935464e3a823539394dcb4669a6e7a889a95ef Mon Sep 17 00:00:00 2001
-From: Robbie Harwood <rharwood@redhat.com>
-Date: Wed, 31 Jan 2018 18:21:04 +0100
-Subject: [PATCH] Turn off -Wcast-function-type
-
-The glib event library forces all callbacks to the same type, even
-when they have different arities. Turn off the gcc warning for this
-gross behavior.
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4084965..dcab593 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -9,7 +9,7 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
-
- AC_PROG_CC_C99
-
--for flag in -Wall -Wextra; do
-+for flag in -Wall -Wextra -Wno-cast-function-type; do
- OLD_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS $flag"
- AC_TRY_COMPILE(, [return 0;], [], [CFLAGS=$OLD_CFLAGS])
diff --git a/dev-libs/libverto/files/libverto-libev-c89.patch b/dev-libs/libverto/files/libverto-libev-c89.patch
deleted file mode 100644
index e63c032b0c89..000000000000
--- a/dev-libs/libverto/files/libverto-libev-c89.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 09ee123..b7b5908 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -7,8 +7,8 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
- [AC_USE_SYSTEM_EXTENSIONS],
- [AC_GNU_SOURCE])
-
--AC_PROG_CC_C89
--for flag in -std=c89 -Wall -Wextra; do
-+AC_PROG_CC_C99
-+for flag in -Wall -Wextra; do
- AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
- done
-
diff --git a/dev-libs/libverto/files/libverto-load.patch b/dev-libs/libverto/files/libverto-load.patch
deleted file mode 100644
index 94dceac5d69c..000000000000
--- a/dev-libs/libverto/files/libverto-load.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From 7989b3c6bdfdeb8770d17d8717b4a0cd48e79386 Mon Sep 17 00:00:00 2001
-From: Robbie Harwood <rharwood@redhat.com>
-Date: Wed, 24 Oct 2018 16:57:11 -0400
-Subject: [PATCH] Fix rare leak of DSO in module_load
-
----
- src/module.c | 31 +++++++++++++++----------------
- 1 file changed, 15 insertions(+), 16 deletions(-)
-
-diff --git a/src/module.c b/src/module.c
-index 1f1b7c9..0b59034 100644
---- a/src/module.c
-+++ b/src/module.c
-@@ -182,7 +182,7 @@ module_load(const char *filename, const char *symbname,
- intdll = dlopen(filename, RTLD_LAZY | RTLD_LOCAL);
- #endif /* WIN32 */
- if (!intdll)
-- return dllerror();
-+ goto fail;
-
- /* Get the module symbol */
- #ifdef WIN32
-@@ -190,16 +190,12 @@ module_load(const char *filename, const char *symbname,
- #else /* WIN32 */
- intsym = dlsym(intdll, symbname);
- #endif /* WIN32 */
-- if (!intsym) {
-- module_close(intdll);
-- return dllerror();
-- }
-+ if (!intsym)
-+ goto fail;
-
- /* Figure out whether or not to load this module */
-- if (!shouldload(intsym, misc, &interr)) {
-- module_close(intdll);
-- return interr;
-- }
-+ if (!shouldload(intsym, misc, &interr))
-+ goto fail;
-
- /* Re-open the module */
- module_close(intdll);
-@@ -208,9 +204,8 @@ module_load(const char *filename, const char *symbname,
- #else /* WIN32 */
- intdll = dlopen(filename, RTLD_NOW | RTLD_LOCAL);
- #endif /* WIN32 */
-- if (!intdll) {
-- return dllerror();
-- }
-+ if (!intdll)
-+ goto fail;
-
- /* Get the symbol again */
- #ifdef WIN32
-@@ -218,14 +213,18 @@ module_load(const char *filename, const char *symbname,
- #else /* WIN32 */
- intsym = dlsym(intdll, symbname);
- #endif /* WIN32 */
-- if (!intsym) {
-- module_close(intdll);
-- return dllerror();
-- }
-+ if (!intsym)
-+ goto fail;
-
- if (dll)
- *dll = intdll;
- if (symb)
- *symb = intsym;
- return NULL;
-+
-+fail:
-+ if (!interr)
-+ interr = dllerror();
-+ module_close(intdll);
-+ return interr;
- }
diff --git a/dev-libs/libverto/files/libverto-verify-cflags.patch b/dev-libs/libverto/files/libverto-verify-cflags.patch
deleted file mode 100644
index dce747239dc7..000000000000
--- a/dev-libs/libverto/files/libverto-verify-cflags.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 5bbe8b009d6daa809f679fd1d25c270abba468b4 Mon Sep 17 00:00:00 2001
-From: Robbie Harwood <rharwood@redhat.com>
-Date: Wed, 31 Jan 2018 17:52:39 +0100
-Subject: [PATCH] Verify flags prior to adding them to CFLAGS, not after
-
----
- configure.ac | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index b7b5908..4084965 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -8,8 +8,11 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
- [AC_GNU_SOURCE])
-
- AC_PROG_CC_C99
-+
- for flag in -Wall -Wextra; do
-- AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
-+ OLD_CFLAGS=$CFLAGS
-+ CFLAGS="$CFLAGS $flag"
-+ AC_TRY_COMPILE(, [return 0;], [], [CFLAGS=$OLD_CFLAGS])
- done
-
- AC_CANONICAL_SYSTEM