summaryrefslogtreecommitdiff
path: root/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild')
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
new file mode 100644
index 000000000000..bfc2a2dc1b40
--- /dev/null
+++ b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="mapping tool for UTF-8 strings"
+HOMEPAGE="http://www.netsurf-browser.org/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-util/netsurf-buildsystem"
+
+S="${WORKDIR}/${MY_P}"
+
+_emake() {
+ source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+}